Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

"One Line Install" does not work #618

Closed
vandrijevik opened this Issue Feb 19, 2011 · 4 comments

Comments

Projects
None yet
2 participants

Following the instructions on http://npmjs.org/ I get the following:

$ curl http://npmjs.org/install.sh | sh
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2820  100  2820    0     0   7321      0 --:--:-- --:--:-- --:--:-- 20000
Not running as root.  Will attempt to use sudo.
0.4.0
git submodule update --init
fatal: Not a git repository (or any of the parent directories): .git
make: *** [submodules] Error 128
sudo failed, attempting with unsafe-perm
git submodule update --init
fatal: Not a git repository (or any of the parent directories): .git
make: *** [submodules] Error 128
It failed

I hope this is helpful:

$ node -v
v0.4.0
$ uname -a
Darwin fermat.local 10.6.0 Darwin Kernel Version 10.6.0: Wed Nov 10 18:13:17 PST 2010; root:xnu-1504.9.26~3/RELEASE_I386 i386
Owner

isaacs commented Feb 19, 2011

Closed by 8b40275 Don't do git on non-git folder

Owner

isaacs commented Feb 19, 2011

Try again. There was a bug in the Makefile.

Yup, worked fine now. Cheers!

Um, in the output of curl http://npmjs.org/install.sh | sh I see that npm@0.3.2 is installed twice, and I see the release notes for it twice. Is this expected?

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment