Permalink
Browse files

add sass-rails as dependency; closes #2

  • Loading branch information...
1 parent b5df6f5 commit b31f071f57aa0930bfb5496d95ef941e251470bc @nragaz committed May 23, 2012
Showing with 80 additions and 106 deletions.
  1. +1 −6 Gemfile
  2. +76 −97 Gemfile.lock
  3. +1 −1 lib/tipsy/rails/version.rb
  4. +2 −2 tipsy-rails.gemspec
View
@@ -1,9 +1,4 @@
source :gemcutter
# Specify your gem's dependencies in jquery-rails.gemspec
-gemspec
-# Rails is already being pulled in through gemspec
-# gem "rails", :git => "git://github.com/rails/rails.git"
-gem "rack", :git => "git://github.com/rack/rack.git"
-gem "sprockets", :git => "git://github.com/sstephenson/sprockets.git"
-gem "i18n", "0.6.0beta1"
+gemspec
View
@@ -1,120 +1,99 @@
-GIT
- remote: git://github.com/rack/rack.git
- revision: a9beb476b27914794743d0677b327d5bafb5e8a3
- specs:
- rack (1.2.1)
-
-GIT
- remote: git://github.com/rails/rails.git
- revision: 2fbbd08616c25dc2931eca914349dd2161766f69
- specs:
- actionmailer (3.1.0.beta)
- actionpack (= 3.1.0.beta)
- mail (~> 2.3.0)
- actionpack (3.1.0.beta)
- activemodel (= 3.1.0.beta)
- activesupport (= 3.1.0.beta)
- builder (~> 3.0.0)
- erubis (~> 2.7.0)
- i18n (~> 0.6.0beta1)
- rack (~> 1.2.1)
- rack-cache (~> 1.0.0)
- rack-mount (~> 0.7.2)
- rack-test (~> 0.5.7)
- sprockets (~> 2.0.0.beta.2)
- tzinfo (~> 0.3.23)
- activemodel (3.1.0.beta)
- activesupport (= 3.1.0.beta)
- bcrypt-ruby (~> 2.1.4)
- builder (~> 3.0.0)
- i18n (~> 0.6.0beta1)
- activerecord (3.1.0.beta)
- activemodel (= 3.1.0.beta)
- activesupport (= 3.1.0.beta)
- arel (~> 2.1.0)
- tzinfo (~> 0.3.23)
- activeresource (3.1.0.beta)
- activemodel (= 3.1.0.beta)
- activesupport (= 3.1.0.beta)
- activesupport (3.1.0.beta)
- multi_json (~> 1.0.0)
- rails (3.1.0.beta)
- actionmailer (= 3.1.0.beta)
- actionpack (= 3.1.0.beta)
- activerecord (= 3.1.0.beta)
- activeresource (= 3.1.0.beta)
- activesupport (= 3.1.0.beta)
- bundler (~> 1.0)
- railties (= 3.1.0.beta)
- railties (3.1.0.beta)
- actionpack (= 3.1.0.beta)
- activesupport (= 3.1.0.beta)
- rack-ssl (~> 1.3.2)
- rake (>= 0.8.7)
- thor (~> 0.14.4)
-
-GIT
- remote: git://github.com/sstephenson/sprockets.git
- revision: c4800417792744c11eb1fb888bbe9a3a82859952
- specs:
- sprockets (2.0.0.beta.2)
- hike (~> 1.0)
- rack (~> 1.0)
- tilt (~> 1.0)
-
PATH
remote: .
specs:
- jquery-rails (0.3)
- rails (~> 3.1)
- thor (~> 0.14.4)
+ tipsy-rails (1.0.2)
+ railties (~> 3.0)
+ sass-rails
GEM
remote: http://rubygems.org/
specs:
- addressable (2.2.4)
- arel (2.1.0)
- bcrypt-ruby (2.1.4)
+ actionmailer (3.2.3)
+ actionpack (= 3.2.3)
+ mail (~> 2.4.4)
+ actionpack (3.2.3)
+ activemodel (= 3.2.3)
+ activesupport (= 3.2.3)
+ builder (~> 3.0.0)
+ erubis (~> 2.7.0)
+ journey (~> 1.0.1)
+ rack (~> 1.4.0)
+ rack-cache (~> 1.2)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.1.2)
+ activemodel (3.2.3)
+ activesupport (= 3.2.3)
+ builder (~> 3.0.0)
+ activerecord (3.2.3)
+ activemodel (= 3.2.3)
+ activesupport (= 3.2.3)
+ arel (~> 3.0.2)
+ tzinfo (~> 0.3.29)
+ activeresource (3.2.3)
+ activemodel (= 3.2.3)
+ activesupport (= 3.2.3)
+ activesupport (3.2.3)
+ i18n (~> 0.6)
+ multi_json (~> 1.0)
+ arel (3.0.2)
builder (3.0.0)
- crack (0.1.8)
erubis (2.7.0)
- hike (1.0.0)
- i18n (0.6.0beta1)
- mail (2.3.0)
+ hike (1.2.1)
+ i18n (0.6.0)
+ journey (1.0.3)
+ json (1.7.3)
+ mail (2.4.4)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.16)
- multi_json (1.0.0)
- polyglot (0.3.1)
- rack-cache (1.0.1)
+ mime-types (1.18)
+ multi_json (1.3.5)
+ polyglot (0.3.3)
+ rack (1.4.1)
+ rack-cache (1.2)
rack (>= 0.4)
- rack-mount (0.7.2)
- rack (>= 1.0.0)
rack-ssl (1.3.2)
rack
- rack-test (0.5.7)
+ rack-test (0.6.1)
rack (>= 1.0)
- rake (0.8.7)
- rspec (1.3.1)
+ rails (3.2.3)
+ actionmailer (= 3.2.3)
+ actionpack (= 3.2.3)
+ activerecord (= 3.2.3)
+ activeresource (= 3.2.3)
+ activesupport (= 3.2.3)
+ bundler (~> 1.0)
+ railties (= 3.2.3)
+ railties (3.2.3)
+ actionpack (= 3.2.3)
+ activesupport (= 3.2.3)
+ rack-ssl (~> 1.3.2)
+ rake (>= 0.8.7)
+ rdoc (~> 3.4)
+ thor (~> 0.14.6)
+ rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
+ sass (3.1.18)
+ sass-rails (3.2.5)
+ railties (~> 3.2.0)
+ sass (>= 3.1.10)
+ tilt (~> 1.3)
+ sprockets (2.1.3)
+ hike (~> 1.2)
+ rack (~> 1.0)
+ tilt (~> 1.1, != 1.3.0)
thor (0.14.6)
- tilt (1.3)
- treetop (1.4.9)
+ tilt (1.3.3)
+ treetop (1.4.10)
+ polyglot
polyglot (>= 0.3.1)
- tzinfo (0.3.27)
- webmock (1.6.2)
- addressable (>= 2.2.2)
- crack (>= 0.1.7)
+ tzinfo (0.3.33)
PLATFORMS
ruby
DEPENDENCIES
- bundler (~> 1.0.0)
- i18n (= 0.6.0beta1)
- jquery-rails!
- rack!
- rails!
- rspec (~> 1.3)
- sprockets!
- webmock (~> 1.6.2)
+ bundler (~> 1.1.0)
+ rails (~> 3.0)
+ tipsy-rails!
@@ -1,6 +1,6 @@
module Tipsy
module Rails
- VERSION = "1.0.2"
+ VERSION = "1.0.3"
TIPSY_VERSION = "1.0.0a"
end
end
View
@@ -14,8 +14,8 @@ Gem::Specification.new do |s|
s.required_rubygems_version = ">= 1.3.6"
s.add_dependency "railties", "~> 3.0"
- s.add_dependency "thor", "~> 0.14"
- s.add_development_dependency "bundler", "~> 1.0.0"
+ s.add_dependency "sass-rails"
+ s.add_development_dependency "bundler", "~> 1.1.0"
s.add_development_dependency "rails", "~> 3.0"
s.files = `git ls-files`.split("\n")

0 comments on commit b31f071

Please sign in to comment.