Permalink
Commits on Apr 10, 2018
  1. release 4.0

    nruth committed Apr 10, 2018
    Adds spport for Capybara 3.
    Might break capybara-webkit tests setting weird cookie values.
    
    Major:
    
    - capybara-webkit cookie values are escaped before setting #38
    - selenium driver assumes Selenium::WebDriver::Error::NoSuchCookieError defined
      (raised by accessing a non-existent cookie, converted to nil)
      82d304e
    
    Enhancements:
    
    - capybara 3 compatible #44
    
    Dev environment:
    
    - selenium tests now headless for chrome and firefox
    - dev deps moved to gemfile. Gemfile lock checked in.
  2. update to capybara 3

    nruth committed Apr 10, 2018
    resolves #44
  3. headless chrome and firefox

    nruth committed Apr 10, 2018
  4. prune readme badges and rspec subheading

    nruth committed Apr 10, 2018
  5. move dev/test deps to gemfile and commit lock

    nruth committed Apr 10, 2018
  6. update for firefox with geckodriver

    nruth committed Apr 10, 2018
    convert Selenium::WebDriver::Error::NoSuchCookieError to nil on get cookie
  7. Merge pull request #38 from darkphnx/master

    nruth committed Apr 10, 2018
    Escape cookie values when creating with Webkit driver
Commits on Jan 5, 2016
  1. Escape cookie values when creating with Webkit driver

    darkphnx committed Jan 5, 2016
Commits on Dec 30, 2015
  1. minor version 3.1.0 (new driver webkit_debug)

    nruth committed Dec 30, 2015
  2. Merge pull request #37 from janosch-x/work-with-webkit_debug

    nruth committed Dec 30, 2015
    register Webkit adapter for :webkit_debug
Commits on Dec 29, 2015
  1. register Webkit adapter for :webkit_debug

    janosch-x committed Dec 29, 2015
    Allows using the driver :webkit_debug, which is just a verbose version of :webkit
Commits on Jul 24, 2015
  1. Merge pull request #34 from ryanlntn/fix/readme

    nruth committed Jul 24, 2015
    Remove unmatched paren
  2. Remove unmatched paren

    ryanlntn committed Jul 24, 2015
Commits on Jul 10, 2015
  1. version 3.0.0 breaks old capybara-webkit

    nruth committed Jul 10, 2015
Commits on Jul 5, 2015
  1. Add support for Capybara-Webkit 1.6.0

    nritholtz committed Jul 5, 2015
Commits on Mar 5, 2015
  1. Merge pull request #30 from MichaelPoP/master

    nruth committed Mar 5, 2015
    Update README
  2. Update README

    MichaelPoP committed Mar 5, 2015
    This README would be easier to understand and use for rails developers with this change
Commits on Feb 11, 2015
  1. Update README.md

    nruth committed Feb 11, 2015
  2. Merge remote-tracking branch 'rossta/rspec_3_compatibility'

    nruth committed Feb 11, 2015
    * rossta/rspec_3_compatibility:
      declare rspec 3.0 development dependency in gemspec
      Address rspec deprecation warnings regarding  syntax
      use new rspec 3 syntax for checking truthiness in custom cookie matchers
    
    Conflicts:
    	show_me_the_cookies.gemspec
    	spec/drivers/poltergeist_spec.rb
    	spec/drivers/rack-test_spec.rb
    	spec/drivers/selenium_spec.rb
    	spec/drivers/webkit_spec.rb
    	spec/spec_helper.rb
  3. add selenium chromedriver adapter & tests

    nruth committed Feb 11, 2015
    Since the adapter is identical for firefox this
    is just to test it in the extra browser; no need
    for people to change adapter in their tests unless
    they want to, just as described in the capybara
    readme about switching to chrome
  4. chased by rubocop

    nruth committed Feb 11, 2015
  5. Merge pull request #27 from rossta/rack_test_http_only

    nruth committed Feb 11, 2015
    Add rack-test cookie support for reading httponly value
  6. Merge pull request #29 from strika/master

    nruth committed Feb 11, 2015
    Add create_cookie to readme
Commits on Jan 26, 2015
  1. Add create_cookie to readme

    strika committed Jan 26, 2015
Commits on Aug 18, 2014
Commits on Aug 11, 2014
  1. Address rspec deprecation warnings regarding syntax

    rossta committed Aug 11, 2014
    Example warning: Using `should` from rspec-expectations' old `:should`
    syntax without explicitly enabling the syntax is deprecated. Use the new
    `:expect` syntax or explicitly enable `:should` instead.
Commits on Jun 27, 2014
  1. add docs coverage badge

    nruth committed Jun 27, 2014
Commits on Jun 24, 2014
  1. add coderwall link

    nruth committed Jun 24, 2014