Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Branch: master
Fetching contributors…

Cannot retrieve contributors at this time

125 lines (80 sloc) 3.18 KB
* Version 2.1.6
Community contributed instrumentation
- ThinkingSphinx instrumentation (W. Andrew Loe III)
- Riak instrumentation (Bryce Kerley)
- KyotoTycoon instrumentation (Keisuke Kawahara)
Community Contributed Bug Fixes
- MongoDB instrumentation (Kenn Ejima)
- Yajl instrumentation (Chris Griego)
- UltraSphinx instrumentation (Jonathan Rudenberg)
Renamed ActiveMQ instrumentation to ActiveMessaging (W. Andrew Loe III)
* Version 2.1.5
Changed the resque detection so it does not depend on the load
order of resque => rpm_contrib => newrelic_rpm. The gems can be
installed in any order.
* Version 2.1.4
Updated requirements to latest agent with some bug fixes for background jobs
Converted instrumentation to install with DependencyDetection in the latest Agent
Changed Resque instrumentation from a plugin back to method chaining
Fixed several reported bugs related to resque
* Version 2.1.3
Fixed typo in Resque instrumentation
Fixed double loading of AWS instrumentation
* Version 2.1.2
Add a manual shutdown to the Resque instrumentation to make sure data is saved and sent - thanks to Jade Rubick
* Version 2.1.1
Fix namespacing problem with Resque
Add instrumentation to Mongo::Cursor #refresh and #close - thanks to Chris Griego
* Version 2.1.0
Included instrumentation from the community:
- Alexey Palazhchenko - mongo ORM-agnostic instrumentation
- Michael Breen - Elastic Search
- Paul Ingles - Sinatra Template instrumentation
- Siddharth Dawara - Typhoeus instrumentation
- Rob Meyer - ActiveMQ instrumentation
- Greg Hazel - Curb instrumentation
- Ben Poweski - Crack and Yajl instrumentation
- Chad Ingram and Scott Fleckenstein - Workling instrumentation
- Adam Weller - UltraSphinx instrumentation
- Liron Yahdav - work on the Resque instrumentation
* Version 2.0.1
Fixed an error with Bundler and RubyGems 1.8.2 which caused the gem to always fail to load
* Version 2.0.0
Updated to use the latest version of the Ruby Agent
* Version 1.0.13
Removed use of 'metaclass' - no longer available from ActiveSupport as of Rails 3
Contributed by Chris Griego
* Version 1.0.12
Better support for initialization within a Rails 3 application
rpm_contrib now depends on newrelic_rpm >= 2.13.1
* Version 1.0.11
AWS/S3 instrumentation contributed by Brian Doll
Cassandra instrumentation contributed by Ashley Martens
Updated Redis instrumentation for 1.x and 2.x contributed by Karl Baum
* Version 1.0.10
Mongoid support contributed by Karl Baum
* Version 1.0.9
Fixed dependency specification on newrelic_rpm
* Version 1.0.8
Redis instrumentation contributed by Ashley Martens
Authlogic moved into RPM Ruby Agent
* Version 1.0.7
Resque instrumentation now supports the resque-multi-job-forks plugin
* Version 1.0.6
Update newrelic dependency: depends on 2.11.1
* Version 1.0.5
Clear stats in forked resque jobs
* Version 1.0.4
Resque support
* Version 1.0.3
MongoDB instrumentation contributed by John Nunemaker
* Version 1.0.2
Improved Camping support
* Version 1.0.1
Removed DelayedJob, put back in core agent
* Version 1.0.0
Initial Release:
- Camping
- Authlogic
- DelayedJob
- Paperclip
Jump to Line
Something went wrong with that request. Please try again.