Outdated bento build instructions #2993

Closed
jpaalasm opened this Issue Feb 16, 2013 · 4 comments

Comments

Projects
None yet
3 participants
Contributor

jpaalasm commented Feb 16, 2013

It is said in BENTO_BUILD.txt that waf should be downloaded with svn. That is strange, as the waf project seems to have a git repository, not svn.

Contributor

jpaalasm commented Feb 16, 2013

ping @cournape

cournape closed this in 38a1648 Feb 16, 2013

Member

cournape commented Feb 16, 2013

Thanks for the bug report, now fixed. Waf has used been using git for some time now.

Owner

rgommers commented Feb 16, 2013

A question while you're at it: is it possible to avoid these environment vars (now or in the long run)? It's not very user-friendly. Why can't I do:

pip install waf
pip install Bento
cd <numpy repo>
bentomaker install

?

Member

cournape commented Feb 17, 2013

On Sat, Feb 16, 2013 at 2:55 PM, Ralf Gommers notifications@github.comwrote:

A question while you're at it: is it possible to avoid these environment
vars (now or in the long run)? It's not very user-friendly. Why can't I do:

You can do pip install Bento for quite some time now, but you can't pip
install waf (waf has no setup.py)

I will think about how to generate a daily single file bentomaker that
contains everything needed to build numpy.

David

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment