Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tapable.plugin is deprecated #185

Closed
goatandsheep opened this issue Feb 12, 2019 · 4 comments

Comments

Projects
None yet
3 participants
@goatandsheep
Copy link

commented Feb 12, 2019

Fresh install gave me this build error:

(node:17605) DeprecationWarning: Tapable.plugin is deprecated. Use new API on .hooks instead

Setup:

  • axios
  • element-ui
  • universal
  • eslint
@manniL

This comment has been minimized.

Copy link
Member

commented Feb 12, 2019

That's no error. It's a warning. Probably from nuxt-community/pwa-module#120 or another module. Not problematic at all

@manniL manniL closed this Feb 12, 2019

@goatandsheep

This comment has been minimized.

Copy link
Author

commented Feb 12, 2019

It shows up as an error for me
Error

@trylovetom

This comment has been minimized.

Copy link

commented Feb 22, 2019

Same Here
Any Update?

@nuxt nuxt locked and limited conversation to collaborators Feb 24, 2019

@manniL

This comment has been minimized.

Copy link
Member

commented Feb 24, 2019

Folks, once again.

  1. This is no problematic error but just a DeprecationWarning. You can notice that by actually reading the error message.
  2. DeprecationWarning means that something will not work in the future but still works.
  3. This is caused by the @nuxtjs/pwa modules and will be fixed the next major version. We can't just release a minor because it's a breaking change.
  4. There is a beta for @nuxtjs/pwa that removes the error. Please try it out 🙏
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.