Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

inject: false in bundleRenderer config not work #5664

Closed
maunier opened this issue May 7, 2019 — with CMTY · 4 comments · Fixed by #5745
Closed

inject: false in bundleRenderer config not work #5664

maunier opened this issue May 7, 2019 — with CMTY · 4 comments · Fixed by #5745

Comments

Copy link
Contributor

@maunier maunier commented May 7, 2019 — with CMTY

Version

v2.6.3

Reproduction link

https://github.com/maunier/nuxt-learning

Steps to reproduce

  1. npm run dev
  2. visit http://localhost:3000/

What is expected ?

html shouldn't load any script because I have configed "inject: false" for bundleRenderer in nuxt.config.js

What is actually happening?

it loads "commons.app.js" "vendors.app.js" and so on.

Additional comments?

i need a template that automaticly inject all the script at IE10+ otherwise don't inject any script

This bug report is available on Nuxt community (#c9162)
@cmty cmty bot added the cmty:bug-report label May 7, 2019
@maunier maunier changed the title inject: false in bundleRenderer config not worke inject: false in bundleRenderer config not work May 7, 2019
@RafaelGSS

This comment has been minimized.

Copy link

@RafaelGSS RafaelGSS commented May 7, 2019

Remove your package-lock.json and install again, the dependencies installed in package-lock.json not match with package.json.

@maunier

This comment has been minimized.

Copy link
Contributor Author

@maunier maunier commented May 8, 2019

Remove your package-lock.json and install again, the dependencies installed in package-lock.json not match with package.json.

I have removed package-lock.json and node_modules and installed again, but the page still loads all the script.

@maunier

This comment has been minimized.

Copy link
Contributor Author

@maunier maunier commented May 10, 2019

Remove your package-lock.json and install again, the dependencies installed in package-lock.json not match with package.json.

I'm so sorry to bother you, but could you help me find out the reason why it not worked.

@RafaelGSS

This comment has been minimized.

Copy link

@RafaelGSS RafaelGSS commented May 10, 2019

@maunier Hello!

recently I've been busy, but today I'll try to verify this.

Maybe, anyone of core nuxt can help you.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.