Skip to content
Permalink
Browse files

Install older version of pyAutoGui to make system tests on AppVeyor w…

…orking again (#9659)

* * Install older version of PyAutoGui as latest release don't work with Python 2.7
* move all dependencies to the separate requirements file and use it when installing on AppVeyor
* update the readme for system tests accordingly

* remove unneded line
  • Loading branch information...
lukaszgo1 authored and michaelDCurran committed May 31, 2019
1 parent e9faffa commit b15bda42edb8d04cde2380cd0f81f800e8303770
Showing with 13 additions and 16 deletions.
  1. +2 −4 appveyor.yml
  2. +2 −12 tests/system/readme.md
  3. +9 −0 tests/system/requirements.txt
@@ -118,10 +118,8 @@ build_script:
- cd ..

before_test:
# Manually grab pyGetWindow 0.0.4 as latest release cannot be installed on Python 2.7.
# See https://github.com/asweigart/PyGetWindow/issues/9
- py -m pip install pygetwindow==0.0.4
- py -m pip install robotframework robotremoteserver nose pyautogui
# install required packages
- py -m pip install -r tests/system/requirements.txt
- mkdir testOutput
- mkdir testOutput\unit
- mkdir testOutput\system
@@ -2,19 +2,9 @@

### Dependencies

The system tests depend on the following:
To install all required packages move to the root directory of this repo and execute:

- Robot Framework
- Robot Remote Server
- PyAutoGui

Which can be installed with `pip`:

```
pip install robotframework
pip install robotremoteserver
pip install pyautogui
```
`python -m pip install -r tests/system/requirements.txt`

### Running the tests

@@ -0,0 +1,9 @@
# Manually grab pyGetWindow 0.0.4 as latest release cannot be installed on Python 2.7.
# See https://github.com/asweigart/PyGetWindow/issues/9
pygetwindow==0.0.4
# Latest version of PyAutoGui requires PyGetWindow=0.0.5 which cannot be installed - see above
# Therefore install last working version
pyautogui==0.9.43
nose
robotframework
robotremoteserver

0 comments on commit b15bda4

Please sign in to comment.
You can’t perform that action at this time.