Creating a portable copy of NVDA in an unknown folder doesn't show the message box #2208

Closed
nvaccessAuto opened this Issue Apr 3, 2012 · 2 comments

1 participant

@nvaccessAuto

Reported by PZajda on 2012-04-03 16:59
1. Go to NVDA Menu>Tools>Create Portable Copy...
2. Type a wrong path then click Continu.

Then we have the error sound and that in the log:
ERROR - gui.installerGui.doCreatePortable (18:49:48):
Failed to create portable copy
Traceback (most recent call last):
File "gui\installerGui.pyc", line 137, in doCreatePortable
File "installer.pyc", line 277, in init
WindowsError: 3 Le chemin d'accès spécifié est introuvable: u'e:\'
ERROR - unhandled exception (18:49:48):
Traceback (most recent call last):
File "gui\installerGui.pyc", line 129, in onCreatePortable
File "gui\installerGui.pyc", line 141, in doCreatePortable
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe8 in position 25: ordinal not in range(128)

@nvaccessAuto

Comment 1 by jteh on 2012-04-03 17:27
Changes:
Milestone changed from None to 2012.2

@nvaccessAuto

Comment 2 by mdcurran on 2012-04-16 12:34
Fixed in f5d2047. The directory is no longer set to the random location of 'e:', instead its left blank. When pressing continue, a message box is shown if the directory is still blank, or the drive does not exist.
Changes:
State: closed

@nvaccessAuto nvaccessAuto added this to the 2012.2 milestone Nov 10, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment