Quick navigation doesn't work for embedded objects and block quotes in Firefox 14 #2287

Closed
nvaccessAuto opened this Issue May 1, 2012 · 6 comments

1 participant

@nvaccessAuto

Reported by ateu on 2012-05-01 21:05
Hi,

Using this version of firefox, (aurora) when arrowing, the embedded object is found. But pressing o, it doesn't ocurrs, even existing an object.

@nvaccessAuto

Comment 1 by jteh on 2012-05-02 04:04
This is caused by a change in Firefox (MozillaBug:736059). The value of the tag object attribute is now lower case where it was previously upper case.
Changes:
Changed title from "NVDA doesn't Announces Embedded Objects when Navigating with quick navigation keys in Firefox 14" to "Quick navigation doesn't work for embedded objects and block quotes in Firefox 14"
Milestone changed from None to 2012.2

@nvaccessAuto

Comment 2 by jteh on 2012-05-02 05:38
Mick, do you think we should:

  1. Change the backend code to lower case the value of the tag object attribute; or
  2. Just add both upper case and lower case versions of the tags when searching (e.g. "blockquote", "BLOCKQUOTE")? 1) is more elegant, but adds an if check for every attribute that will fail most of the time. However, it might be more future proof.
@nvaccessAuto

Comment 3 by jteh on 2012-05-03 01:07
I actually went with another option. :)

Fixed in cd4db2e. This also fixes quick navigation to block quotes in Google Chrome.
Changes:
State: closed

@nvaccessAuto

Comment 5 by elliott94 (in reply to comment 4) on 2012-08-02 13:17
Replying to jteh:

Keywords MozillaGrantMay2011 added

I'm assuming that this should be 2010? :)

@nvaccessAuto

Comment 6 by elliott94 (in reply to comment 5) on 2012-08-02 13:18
Replying to elliott94:

Replying to jteh:

Keywords MozillaGrantMay2011 added

I'm assuming that this should be 2010? :)

Sorry; I meant 2012. No idea where I got 2010 from.

@nvaccessAuto

Comment 7 by jteh (in reply to comment 6) on 2012-08-07 06:21
Replying to elliott94:

Keywords MozillaGrantMay2011 added

I'm assuming that this should be ![2012]? :)

No. I'm identifying the grant by when it began, which was May 2011.

@nvaccessAuto nvaccessAuto added this to the 2012.2 milestone Nov 10, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment