Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

When running from source code NVDA crashes #237

Closed
nvaccessAuto opened this Issue Jan 1, 2010 · 3 comments

Comments

Projects
None yet
1 participant
@nvaccessAuto
Copy link

nvaccessAuto commented Jan 1, 2010

Reported by heiko_folkerts@... on 2008-11-24 19:11
To Run NVDA from Source code I did: 1. Update from subversion. 2. Installed all Dependencies as said in dependencies.txt. 3 Ran generate.py without getting a strange message and 4. run NVDA.PYW. I get the starting sound, a Crash sound (before any speaking) and the shutdown sound. This is the contes from nvda.log: INFO - nvda (19:53:16):
Starting NVDA
INFO - core.main (19:53:17):
Config dir: E:\nvda-sources\source
INFO - config.save (19:53:17):
Configuration saved
INFO - core.main (19:53:17):
NVDA version trunk-r2526
INFO - core.main (19:53:17):
Using Windows version (5, 1, 2600, 2, 'Service Pack 3')
INFO - core.main (19:53:17):
Using Python version 2.6 (r26:66721, Oct 2 2008, 11:35:03) v.1500 32 bit (Intel)
INFO - core.main (19:53:17):
Using comtypes version 0.5.2
CRITICAL - nvda (19:53:20):
core failure
Traceback (most recent call last):
File "E:\nvda-sources\source\nvda.pyw", line 108, in
core.main()
File "E:\nvda-sources\source\core.py", line 74, in main
import speechDictHandler
File "E:\nvda-sources\source\speechDictHandler.py", line 12, in
import synthDriverHandler
File "E:\nvda-sources\source\synthDriverHandler.py", line 9, in
import baseObject
File "E:\nvda-sources\source\baseObject.py", line 11, in
from keyUtils import key
File "E:\nvda-sources\source\keyUtils.py", line 12, in
import wx
File "C:\programme\Python26\lib\site-packages\wx-2.8-msw-unicode\wx__init__.py", line 45, in
from wx._core import *
File "C:\programme\Python26\lib\site-packages\wx-2.8-msw-unicode\wx_core.py", line 4, in
import core
ImportError: DLL load failed: Das angegebene Modul wurde nicht gefunden.

@nvaccessAuto

This comment has been minimized.

Copy link
Author

nvaccessAuto commented Jan 1, 2010

Attachment nvda.log added by heiko_folkerts@... on 2008-11-24 19:14
Description:
nvda.log as written by the crashed NVDA run

@nvaccessAuto

This comment has been minimized.

Copy link
Author

nvaccessAuto commented Jan 1, 2010

Comment 1 by pvagner on 2008-11-25 10:55
This looks as wxpython is not correctly installed or you are running incompatible version. Can you please try reinstalling wxpython. Also if you are able to then you might like to try running some sample wxpython application to verify my assumption.
Changes:
Changed title from "When compiling NVDA from source code NVDA crashes when running NVDA.pyw" to "When running from source code NVDA crashes"

@nvaccessAuto

This comment has been minimized.

Copy link
Author

nvaccessAuto commented Jan 1, 2010

Comment 2 by heiko_folkerts@... on 2008-11-26 17:40
The suggestion was absolutly correct. I installed a WXP-Python package for Python 2.3. This was not very obvious when downloading, since the download page is very graphical in this case. There was an error when installing it and trying to compile the packages. So this should be made clear to any NVDA user, who will collect this dependencies, that he will need to check the versin first. The error only disapeared, wen removing additional folders where the wxp package was installed. Oterwise the wrong packages gets loaded. Maybe the exact link to the needed package should be noted somewhere.
Changes:
State: closed

@nvaccessAuto nvaccessAuto added the bug label Nov 10, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.