New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Navigation problem in word documents #2402

Closed
nvaccessAuto opened this Issue Jun 1, 2012 · 9 comments

Comments

Projects
None yet
1 participant
@nvaccessAuto

nvaccessAuto commented Jun 1, 2012

Reported by surveyor on 2012-06-01 12:34
Couldn't navigate backward in a listed style paragraph in a word document. The problem is with ctrl+up arrowing and left arrowing. No problem in line by line reading.
To reproduce:
open a a word document which has listed style paragraphs.
Navigate to the paragraph containing a list.
On any item, try to go back using ctrl+up arrow.
And
at the beginning of an item try to go back a character using left arrow.
you can try these on the sample document attached.

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Jun 1, 2012

Attachment Sample.doc added by surveyor on 2012-06-01 12:36
Description:
sample for reproducing

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Jun 3, 2012

Comment 1 by jteh on 2012-06-03 22:56
These commands are application commands, not NVDA commands. If they don't work properly, it's almost certainly due to Word not implementing them.

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Jun 4, 2012

Comment 2 by surveyor on 2012-06-04 17:11
But It does if NVDA is closed?

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Jun 4, 2012

Comment 3 by jteh on 2012-06-04 23:07
Are you saying the cursor doesn't move when you press these keys or NVDA doesn't report the movement? The distinction is important.

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Jun 5, 2012

Comment 4 by surveyor (in reply to comment 3) on 2012-06-05 02:44
Replying to jteh:

Are you saying the cursor doesn't move when you press these keys or NVDA doesn't report the movement? The distinction is important.

I'm trying to say, the cursor doesn't move. But it moves while NVDA is closed. go to previous paragraf command doesn't move the cursor as expected. besides, go to previous char (left arrow) and go to previous word (ctrl+left arrow) doesn't move the cursor if it's at the beginning of the list item. As I guess, the problem is between NVDA and the bullets used by MS Word for listing.

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Jun 20, 2012

Comment 5 by surveyor on 2012-06-20 12:40
I think the problem addressed in this ticket wil disappear when the ticket #2446 resolved.

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Jun 21, 2012

Comment 6 by jteh on 2012-06-21 01:15
This won't be solved by #2446.

Do you have braille enabled? If so, does the problem go away if you disable braille?

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Jun 21, 2012

Comment 7 by surveyor (in reply to comment 6) on 2012-06-21 05:32
Replying to jteh:

This won't be solved by #2446.

Do you have braille enabled? If so, does the problem go away if you disable braille?

I don't have a braille display.

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Aug 20, 2012

Comment 8 by mdcurran on 2012-08-20 20:01
Fixed in 4700f56.
Changes:
Milestone changed from None to 2012.3
State: closed

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment