Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

label for & button label works improper in IE #3711

Closed
nvaccessAuto opened this issue Dec 11, 2013 · 6 comments
Closed

label for & button label works improper in IE #3711

nvaccessAuto opened this issue Dec 11, 2013 · 6 comments

Comments

@nvaccessAuto
Copy link

@nvaccessAuto nvaccessAuto commented Dec 11, 2013

Reported by tutej on 2013-12-11 15:21
I'm developing web application for accessibility support and I came across a problem.

I've created field containing the following elements: Label1 associated with an disabled input field and button containing its own Label2. Then I tested it whether it will work in a such way:

when it moves to the button using the TAB NVDA should say

  1. Name of Label1
  2. Button
  3. Label2

In Firefox everything is running ok,
but in IE Label2 is lost.

I made a simple html page and attached it to the ticket.

I would like to ask whether it is an IE bug, NVDA error or just my mistake.

Thanks for response.
Blocked by #3158

@nvaccessAuto
Copy link
Author

@nvaccessAuto nvaccessAuto commented Dec 11, 2013

Comment 1 by jteh on 2013-12-11 21:46
I don't understand. Can you please explain what you expect for your test case? Your test case doesn't have label 1 and label 2; it has label and button label. If I understand correctly, you're saying you expect the input label to be read for the button, but this doesn't make sense.

Loading

@nvaccessAuto
Copy link
Author

@nvaccessAuto nvaccessAuto commented Dec 12, 2013

Comment 2 by tutej on 2013-12-12 09:17
Ok, I have not explained what I want to use it.

User use the button to get to a library(just like in a drop box) and select option to fill the input with chosen value.

I've added a title (same as field label) to the button and set button label

name button

User is navigating on form with TAB button. He have to know both: actual field label (in Example it's 'Label1') and the button name ('Label2')

I expect that NVDA will read both : title atribute & button label. In FF it works correct, but in IE8 it doesn't.

P.S. I've changed labels

Loading

@nvaccessAuto
Copy link
Author

@nvaccessAuto nvaccessAuto commented Dec 12, 2013

Attachment NewFile3.html.html added by tutej on 2013-12-12 13:14
Description:

Loading

@nvaccessAuto
Copy link
Author

@nvaccessAuto nvaccessAuto commented Dec 12, 2013

Attachment NewFile3.html added by tutej on 2013-12-12 13:15
Description:

Loading

@nvaccessAuto
Copy link
Author

@nvaccessAuto nvaccessAuto commented Dec 12, 2013

Comment 3 by jteh on 2013-12-12 22:31
This is a fairly strange way to implement grouping of widgets. I'd probably recommend a fieldset or similar.

That said, I think I understand the issue now. Can you confirm that after tabbing to the button, pressing NVDA+tab reads the title as expected?

Technical: I guess we don't seem to add the title as the description attribute for MSHTML virtual buffer nodes.

Loading

@nvaccessAuto
Copy link
Author

@nvaccessAuto nvaccessAuto commented Apr 10, 2015

Comment 4 by jteh on 2015-04-10 02:21
Duplicate of #3158.
Changes:
Added labels: duplicate
State: closed

Loading

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant