Ubuntu 12.10, Gnome 3.6, Error when trying to open existing/new note. #160

Closed
noisufnoc opened this Issue Nov 28, 2012 · 9 comments

Comments

Projects
None yet
2 participants
@noisufnoc

Hi!

I followed the debug directions in the Readme and found this error:

Traceback (most recent call last):
File "/usr/lib/pymodules/python2.7/everpad/pad/indicator.py", line 145, in create
editor = self.open(note)
File "/usr/lib/pymodules/python2.7/everpad/pad/indicator.py", line 122, in open
editor = Editor(self.app, note)
File "/usr/lib/pymodules/python2.7/everpad/pad/editor.py", line 856, in init
self.init_controls()
File "/usr/lib/pymodules/python2.7/everpad/pad/editor.py", line 884, in init_controls
self.ui.resourceLabel, self.mark_touched,
File "/usr/lib/pymodules/python2.7/everpad/pad/editor.py", line 699, in init
self.mime = magic.open(magic.MIME_TYPE)
AttributeError: 'module' object has no attribute 'open'

Everpad version: 2.0.1
API version: 1
Schema version: 1

Installed from ppa

@nvbn

This comment has been minimized.

Show comment Hide comment
@nvbn

nvbn Nov 28, 2012

Owner

python-magic is installed from repo or pip?
And maybe it's a duplicate of #41

Owner

nvbn commented Nov 28, 2012

python-magic is installed from repo or pip?
And maybe it's a duplicate of #41

@noisufnoc

This comment has been minimized.

Show comment Hide comment
@noisufnoc

noisufnoc Nov 28, 2012

Damn, looks to be the same issue. Searching > Me.

What's the preferred method of installing python-magic?

python -c 'import magic; print magic.MIME'
Traceback (most recent call last):
File "", line 1, in
AttributeError: 'module' object has no attribute 'MIME'

Damn, looks to be the same issue. Searching > Me.

What's the preferred method of installing python-magic?

python -c 'import magic; print magic.MIME'
Traceback (most recent call last):
File "", line 1, in
AttributeError: 'module' object has no attribute 'MIME'

@nvbn

This comment has been minimized.

Show comment Hide comment
@nvbn

nvbn Nov 28, 2012

Owner

Prefered method is using version from repository. But with latest version from pip it works.
For solving your problem try to reinstall python-magic.

Owner

nvbn commented Nov 28, 2012

Prefered method is using version from repository. But with latest version from pip it works.
For solving your problem try to reinstall python-magic.

@noisufnoc

This comment has been minimized.

Show comment Hide comment
@noisufnoc

noisufnoc Nov 28, 2012

I removed python-magic, and reinstalled from the repo and am experiencing the same error.

What version of python-magic do I need?

I removed python-magic, and reinstalled from the repo and am experiencing the same error.

What version of python-magic do I need?

@nvbn

This comment has been minimized.

Show comment Hide comment
@nvbn

nvbn Nov 28, 2012

Owner

I have installed 5.11. Try to

pip uninstall magic
Owner

nvbn commented Nov 28, 2012

I have installed 5.11. Try to

pip uninstall magic
@noisufnoc

This comment has been minimized.

Show comment Hide comment
@noisufnoc

noisufnoc Nov 28, 2012

Same issue.

sudo pip uninstall python-magic
Uninstalling python-magic:
/usr/local/lib/python2.7/dist-packages/magic.py
/usr/local/lib/python2.7/dist-packages/magic.pyc
/usr/local/lib/python2.7/dist-packages/python_magic-0.4.3.egg-info
Proceed (y/n)? y
Successfully uninstalled python-magic

sudo pip install python-magic
Downloading/unpacking python-magic
Downloading python-magic-0.4.3.tar.gz
Running setup.py egg_info for package python-magic

Installing collected packages: python-magic
Running setup.py install for python-magic

Successfully installed python-magic
Cleaning up...

Same issue.

sudo pip uninstall python-magic
Uninstalling python-magic:
/usr/local/lib/python2.7/dist-packages/magic.py
/usr/local/lib/python2.7/dist-packages/magic.pyc
/usr/local/lib/python2.7/dist-packages/python_magic-0.4.3.egg-info
Proceed (y/n)? y
Successfully uninstalled python-magic

sudo pip install python-magic
Downloading/unpacking python-magic
Downloading python-magic-0.4.3.tar.gz
Running setup.py egg_info for package python-magic

Installing collected packages: python-magic
Running setup.py install for python-magic

Successfully installed python-magic
Cleaning up...
@nvbn

This comment has been minimized.

Show comment Hide comment
@nvbn

nvbn Nov 28, 2012

Owner

Hm, if you try to remove version from pip and reinstall it from repo?

Owner

nvbn commented Nov 28, 2012

Hm, if you try to remove version from pip and reinstall it from repo?

@noisufnoc

This comment has been minimized.

Show comment Hide comment
@noisufnoc

noisufnoc Nov 28, 2012

That seems to have done it. Working like a champ now. Thanks!!

python -c 'import magic; print magic.MIME'
1040

That seems to have done it. Working like a champ now. Thanks!!

python -c 'import magic; print magic.MIME'
1040
@nvbn

This comment has been minimized.

Show comment Hide comment
@nvbn

nvbn Nov 28, 2012

Owner

Ok =)

Owner

nvbn commented Nov 28, 2012

Ok =)

@nvbn nvbn closed this Nov 28, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment