Skip to content

Nothing works after authorization in Arch Linux #300

Open
genghizkhan91 opened this Issue Mar 28, 2013 · 11 comments
@genghizkhan91

Hello. My DE is KDE, first of all, and I'm using the version of Everpad in Arch's AUR. After authorization (which proceeded smoothly), I run everpad-provider in one terminal, and everpad in another. I get this error:

Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 76, in update
20, Note.ORDER_UPDATED_DESC, 1,
File "/usr/lib/python2.7/site-packages/everpad/tools.py", line 32, in wrapper
return getattr(self.interface, name)(args, *kwargs)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call

return self.proxy_method(args, *keywords)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call_

*keywords)
File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.sqlalchemy.exc.InvalidRequestError: Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/dbus/service.py", line 707, in _message_cb
retval = candidate_method(self, *args, *
keywords)
File "/usr/lib/python2.7/site-packages/everpad/provider/service.py", line 101, in find_notes
qs = self.sq(Note).filter(and_(
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/session.py", line 1105, in query
return self.query_cls(entities, self, **kwargs)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 115, in __init_

self.set_entities(entities)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 124, in set_entities
self._set_entity_selectables(self._entities)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 157, in _set_entity_selectables
ent.setup_entity(*d[entity])
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 2744, in setup_entity
self._with_polymorphic = ext_info.with_polymorphic_mappers
File "/usr/lib/python2.7/site-packages/sqlalchemy/util/langhelpers.py", line 582, in __get

obj.dict[self.name] = result = self.fget(obj)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/mapper.py", line 1425, in _with_polymorphic_mappers
configure_mappers()
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/mapper.py", line 2103, in configure_mappers
raise e
InvalidRequestError: One or more mappers failed to initialize - can't proceed with initialization of other mappers. Original exception was: Can't determine relationship direction for relationship 'Note.conflict_parent' - foreign key columns within the join condition are present in both the parent and the child's mapped tables. Ensure that only those columns referring to a parent column are marked as foreign, either via the foreign() annotation or via the foreign_keys argument.

"everpad --create" also gives me the same error. Even "everpad-provider --verbose" gives me no error output. There is no window, nothing.

@acmzero
acmzero commented Apr 4, 2013

Same error here

@Tobi042
Tobi042 commented Apr 9, 2013

Same here but with Gnome 3.6

@rustikus

Same problem here with Gnome 3.6

@jeffsharpe

Same error here - Everpad 2.5.6-1 off the AUR as well.

@l0ckpix
l0ckpix commented Apr 25, 2013

Same error here on Gentoo and KDE.

@woprandi
woprandi commented May 1, 2013

Same

@bitthegeek

same here - openbox

@l0ckpix
l0ckpix commented May 26, 2013

i downgraded sqlalchemy to 0.7.9 (0.8.1 and 0.8.0 dont work!). Not it works for me.

@anpieber

yep sqlalchemy is the problem. You think its possible to upgrade?

@mgaunard

Also affects Ubuntu 13.10...

@trivoallan

Downgrading to python-alchemy and python-alchemy-ext 0.7.9 on Ubuntu 13.10 did not fix the problem.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.