Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Commits on Aug 24, 2014
  1. Declare test deps correctly.

    authored
  2. Also target Python 3.4 on Travis.

    authored
Commits on Aug 23, 2014
  1. Bump version to 0.7.

    authored
  2. Add note on maintenance.

    authored
  3. Declare arrow dependency.

    authored
  4. Sort imports.

    authored
Commits on Jul 24, 2014
  1. Update to SVG image.

    authored
  2. Add wheel support to times.

    authored
  3. Switch to using direnv.

    authored
  4. Merge pull request #12 from dbader/master

    authored
    Generate coverage data and prepare integration with Coveralls.io
Commits on Jul 29, 2013
  1. Prepare for 0.6.2.

    authored
  2. Merge pull request #13 from selwin/master

    authored
    Update setup.py to work around a bug where pytz doesn't install on pip >= 1.4
  3. @selwin
Commits on May 31, 2013
  1. @dbader

    Generate coverage data and prepare integration with Coveralls.io

    dbader authored
    I've updated the Travis build file and the Tox config to run nosetests
    with the --with-coverage parameter. The resulting coverage information
    can then be automatically submitted to Coveralls.io after each Travis
    build (via the coveralls module).
    
    I've also embedded a coverage badge to README.md so that we get a nice
    coverage status once the repo is connected to Coveralls.
Commits on Feb 11, 2013
  1. Bump version to 0.6.1.

    authored
  2. Remove run_tests. Just run 'tox'.

    authored
  3. Switch to nose.

    authored
  4. Fix Travis build configuration.

    authored
Commits on Feb 5, 2013
  1. Merge pull request #11 from ming13/readme-syntax-highlighting

    authored
    Use syntax highlighting in the readme file
  2. @ming13
Commits on Oct 27, 2012
  1. Merge pull request #8 from jparise/typeerrors

    authored
    Raise TypeErrors for invalid argument types.
Commits on Oct 26, 2012
  1. @jparise
  2. @jparise
Commits on Oct 15, 2012
  1. Bump version to 0.6.

    authored
  2. Add PyPy support.

    authored
  3. Don't depend on six.

    authored
    Times a tiny library and it already has two dependencies, which I think
    is one too many already.  Let's not make it two :)
  4. Add tox tests.

    authored
  5. Change Travis build status URL.

    authored
  6. Nose version doens't matter.

    authored
  7. @svetlyak40wt

    Fixes setup.py for python3.

    svetlyak40wt authored
    Python3 requires explicit globals dictionary to be passed to `exec`
    function.
Something went wrong with that request. Please try again.