Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Imported OBJ meshes texture bug? #77

Open
LaddieErvin opened this issue Mar 4, 2018 · 2 comments
Open

Imported OBJ meshes texture bug? #77

LaddieErvin opened this issue Mar 4, 2018 · 2 comments

Comments

@LaddieErvin
Copy link

@LaddieErvin LaddieErvin commented Mar 4, 2018

When importing OBJ files as meshes, the textures don't seem to map correctly unless you first rotate them 90 degrees clockwise and then flip them vertically (in Photoshop or some other software).

Meshes with textures imported directly from Google Poly work just fine as-is so I assume the need to rotate and flip textures for imported OBJ meshes is a bug.

@keenanco

This comment has been minimized.

Copy link

@keenanco keenanco commented Apr 10, 2018

I'm having the same issues with .obj imports. Almost appears as if my models are only lit unidirectionally. Seems like a texture mapping issue.

@LaddieErvin

This comment has been minimized.

Copy link
Author

@LaddieErvin LaddieErvin commented Apr 10, 2018

It's a known issue. Currently, The two work arounds I use are, either rotating the textures 90 degrees clockwise and then flipping them vertically, or uploading the OBJs with textures to Google Poly and then importing them into Anim VR via the Google Poly import feature. You may also have to toggle the lit/unlit button on import.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.