Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

minimal mingw support

  • Loading branch information...
commit 3634f870de977f38ae3ea81ee0abef4e7e17e245 1 parent 5425e22
Roumen Petrov authored veillard committed
Showing with 9 additions and 2 deletions.
  1. +9 −2 configure.in
11 configure.in
View
@@ -141,12 +141,17 @@ AC_SUBST(VERSION_SCRIPT_FLAGS)
AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -n "$VERSION_SCRIPT_FLAGS"])
dnl Look for pthread.h, needed for testThreads
+case $host in
+ *-mingw*) ;;
+ *)
THREAD_LIBS=""
AC_CHECK_HEADER(pthread.h,
AC_CHECK_LIB(pthread, pthread_join,[
AC_DEFINE([HAVE_LIBPTHREAD], [], [Define if pthread library is there (-lpthread)])
AC_DEFINE([HAVE_PTHREAD_H], [], [Define if <pthread.h> is there])
THREAD_LIBS="-lpthread"]))
+ ;;
+esac
AC_SUBST(THREAD_LIBS)
@@ -546,12 +551,14 @@ then
XMLVERS=`$XML_CONFIG --version`
if test VERSION_TO_NUMBER(echo $XMLVERS) -ge VERSION_TO_NUMBER(echo $LIBXML_REQUIRED_VERSION)
then
- LIBXML_LIBS="$LIBXML_LIBS `$XML_CONFIG --libs`"
- LIBXML_CFLAGS="$LIBXML_CFLAGS `$XML_CONFIG --cflags`"
AC_MSG_RESULT($XMLVERS found)
else
AC_MSG_ERROR(Version $XMLVERS found. You need at least libxml2 $LIBXML_REQUIRED_VERSION for this version of libxslt)
fi
+ LIBXML_LIBS="$LIBXML_LIBS `$XML_CONFIG --libs`"
+ if test "x$LIBXML_SRC" = "x"; then
+ LIBXML_CFLAGS="$LIBXML_CFLAGS `$XML_CONFIG --cflags`"
+ fi
else
AC_MSG_ERROR([Could not find libxml2 anywhere, check ftp://xmlsoft.org/.])
fi
Please sign in to comment.
Something went wrong with that request. Please try again.