node webkit source downloads every time i run task #54

Closed
gowram opened this Issue Jan 31, 2014 · 9 comments

Comments

Projects
None yet
4 participants

gowram commented Jan 31, 2014

Hi,
whenever i run task using grunt-node-webki-builder fresh copy of
node-webkit-v0.8.4-win-ia32.zip gets downloaded (which takes longer time to build).

Is it possible to use existing source from local directory instead of downloading fresh copy every time.

regards
Rama

Contributor

steffenmllr commented Jan 31, 2014

Do you delete the cache folder within your build process? it should only download it once

gowram commented Feb 3, 2014

No, I haven't deleted cache folder, Its automatically delete and download again..

Contributor

vladikoff commented Feb 3, 2014

@gowram Could you please post your Grunt configuration please?

gowram commented Feb 4, 2014

//this is my Gruntfile...

module.exports = function(grunt) {
  grunt.initConfig({
    nodewebkit: {
      options: {
        build_dir: './build', // Where the build version of my node-webkit app is saved
       //credits: './public/credits.html',
        win_icns: './octaveApp/logo.png', // Path to the Mac icon file
        mac: false, // We want to build it for mac
        win: true, // We want to build it for win
        linux32: false, // We don't need linux32
        linux64: false, // We don't need linux64
      },
      src: './octaveApp/**/*' // Your node-webkit app
    },
  });
  grunt.loadNpmTasks('grunt-node-webkit-builder');
  grunt.registerTask('default', ['nodewebkit']);
};
Contributor

steffenmllr commented Feb 4, 2014

apart from there is no win_icns option, this should be ok. Can you do me a favor and try the following:

git clone git@github.com:mllrsohn/grunt-node-webkit-builder.git
cd grunt-node-webkit-builder/example
npm install
grunt

Check if the build was ok and runt it again to see it it downloads the files again

gowram commented Feb 4, 2014

I executed as mentioned ..
yes, even this script also gets downloading fresh copy of node-webkit-v0.8.4-win-ia32.zip file each time while running in grunt in windows xp.

Contributor

steffenmllr commented Feb 4, 2014

So you are using WindowsXP? I don't really have a XP System lying around for testing. Which node version are you using?

gowram commented Feb 4, 2014

I am using Node v0.10.25 under window XP

Contributor

gabepaez commented Aug 2, 2014

@gowram Major changes have been made to this project. Please try updating to the latest version and if this is still an issue please repost to the new parent module https://github.com/mllrsohn/node-webkit-builder/issues. Thanks!

gabepaez closed this Aug 2, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment