New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error: Extranonce2 size is 2 (minimum is 4). #365

Open
airatru opened this Issue May 3, 2018 · 1 comment

Comments

Projects
None yet
1 participant
@airatru

airatru commented May 3, 2018

Greetings,
I'm getting this error from Nicehash pool testing. Extra nonce subscribe option doesn't change anything (I'm not sure if it should, its the only option I found mentioning extra nonce.) Any solution for this? Thank you.

@airatru

This comment has been minimized.

airatru commented May 3, 2018

It seems that I found an answer on bitcointalk:

"Hey guys.
I want to connect Nicehash to my proxy. But it got the error: "Disconnected. Remote pool extranonce2 size too small (min=4)." from Nicehash.
Can I set the extranonce2 to 4 anywhere?

Greetings

You want to connect your proxy to Nicehash, not Nicehash to your proxy. The error is from your proxy, not from Nicehash, and it says that Nicehash, not your proxy, is using too small extranonce2. Your proxy expects the size to be at least 4, Nicehash says 3. There is nowhere you could set 4 as you obviously cannot change how Nicehash servers are configured. The only way would be to make the proxy accept size 3."

Is there any way to make stratum proxy to accept extranonce size to be 2 or 3?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment