Hub for the 2018 Midterms
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
app
config
cypress
fastboot/initializers
lib/unobtrusive-loader
mirage
public
tests
vendor
.dockerignore
.editorconfig
.ember-cli
.env.deploy.sample
.env.sample
.eslintignore
.eslintrc.js
.gitignore
.travis.yml
.watchmanconfig
Dockerfile
README.md
circle.yml
cypress.json
ember-cli-build.js
fastboot.js
package.json
testem.js
yarn.lock

README.md

nypr-midterms

This fastboot app is hosted at https://midterms.wnyc.org and serves as the landing page for all midterms-related content.

Prerequisites

You will need the following things properly installed on your computer.

Installation

  • git clone git@github.com:nypublicradio/nypr-midterms this repository
  • cd nypr-midterms
  • yarn install

Running / Development

Code Generators

Make use of the many generators for code, try ember help generate for more details

Running Tests

  • ember test
  • ember test --server

Linting

  • yarn lint:js
  • yarn lint:js --fix

Building

  • ember build (development)
  • ember build --environment production (production)

Deploying

Specify what it takes to deploy your app.

Further Reading / Useful Links