Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Scripts terminate with unknown status when ControlPassword contains special characters #452

Closed
BernCarney opened this issue Sep 28, 2017 · 3 comments

Comments

Projects
None yet
2 participants
@BernCarney
Copy link
Contributor

commented Sep 28, 2017

Took me a while to figure out why my extension scripts weren't working. They would execute and then terminate with unknown status every time. Turns out that if you have special characters at the end of the ControlUser password (in my case #@!) it fails to build the rpcUrl correctly. Removing those characters from the end of my password fixed the problem.

Thu Sep 28 00:23:29 2017        ERROR   Post-process-script Logger.py for [File name being post-processed] failed (terminated with unknown status)

I can add the characters back to my password if you would like a log of what's going on with the scripts.

@hugbug

This comment has been minimized.

Copy link
Member

commented Sep 28, 2017

my extension scripts

Do you mean default scripts Logger.py and Email.py or scripts you wrote yourself?

In the default scripts the username and password are not properly converted into URL format. If you can fix this I'll gladly accept a pull request.

@BernCarney

This comment has been minimized.

Copy link
Contributor Author

commented Sep 28, 2017

Sorry for the confusing wording, I meant any extensions scripts I tried default (Logger and Email) and others (Completion, Safe Rename, and a few others).

I'll see what I can do about fixing it but my scripting knowledge is quite a bit behind my problem solving (aka bang it with a hammer in different spots until it works)... so no promises.

@BernCarney

This comment has been minimized.

Copy link
Contributor Author

commented Sep 28, 2017

I figured it out, I'll put in a PR for the fix in a few min.

hugbug added a commit that referenced this issue Oct 5, 2017

#452, #453: proper URL encoding in example pp-scripts
Updated scripts to accept special characters in nzbget password and username.

@hugbug hugbug closed this Oct 5, 2017

hugbug added a commit that referenced this issue Oct 9, 2017

#452, #453: proper URL encoding in example pp-scripts
Updated scripts to accept special characters in nzbget password and username.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.