New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Ensure node version is compatible with eslint + nvmrc #224

Merged
merged 1 commit into from Oct 7, 2018

Conversation

Projects
None yet
2 participants
@slorber
Contributor

slorber commented Jul 23, 2018

Because

error eslint@5.2.0: The engine "node" is incompatible with this module. Expected version "^6.14.0 || ^8.10.0 || >=9.10.0".

nvmrc is helpful to switch to correct node version for those using nvm

@iRoachie

This comment has been minimized.

Collaborator

iRoachie commented Oct 7, 2018

Is this something we'll have to keep updating as node versions go up?

@slorber

This comment has been minimized.

Contributor

slorber commented Oct 7, 2018

you update the node version when you want to, it's just the recommended version the lib maintainers/contributors should rather use, does not force them to actually use this exact version
N
I use AVN + NVM; which automatically switches me to the .nvmrc version when I do "cd react-native-collapsible"

@iRoachie

This comment has been minimized.

Collaborator

iRoachie commented Oct 7, 2018

Ahh that's pretty nice. Thanks for info!

@iRoachie iRoachie changed the base branch from master to next Oct 7, 2018

@iRoachie iRoachie force-pushed the oblador:next branch from 8a5e051 to 8f79b3e Oct 7, 2018

@iRoachie iRoachie removed the awaiting-reply label Oct 7, 2018

@iRoachie iRoachie changed the title from ensure node version is compatible with eslint + nvmrc to Ensure node version is compatible with eslint + nvmrc Oct 7, 2018

@iRoachie iRoachie merged commit 40d9c46 into oblador:next Oct 7, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@iRoachie iRoachie referenced this pull request Oct 16, 2018

Closed

Can't install new version #252

iRoachie added a commit that referenced this pull request Oct 17, 2018

fix: Partially revert #224
Engines versions were breaking ci for some users

iRoachie added a commit that referenced this pull request Oct 17, 2018

fix: Partially revert #224
Fixes #252

Engines versions were breaking ci for some users
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment