Skip to content

Sphinx documentation

Bernhard Morgenstern edited this page Apr 6, 2014 · 5 revisions

The API reference documentation of ObsPy is generated with Sphinx. In order to build it on your local machine, run

#!sh
cd /path/to/obspy/misc/docs
make pep8
make coverage
make html

Sphinx version 1.1 or higher has to be installed (e.g. via easy_install sphinx==1.1). In case of error messages involving matplotlib.sphinxext try updating the matplotlib installation.

A fully self-contained script to install a local Python environment suitable for building the docs from scratch is available here: https://github.com/obspy/sandbox/blob/master/buildbots/install_python.sh

More useful links on Sphinx:

Something went wrong with that request. Please try again.