Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

more helpful error message with incompatible .cmis #3662

Closed
vicuna opened this Issue May 24, 2005 · 1 comment

Comments

Projects
None yet
2 participants
@vicuna
Copy link
Collaborator

vicuna commented May 24, 2005

Original bug ID: 3662
Reporter: administrator
Assigned to: @gasche
Status: closed (set by @xavierleroy on 2015-07-24T08:39:00Z)
Resolution: fixed
Priority: normal
Severity: feature
Fixed in version: 4.00.0
Category: ~DO NOT USE (was: OCaml general)

Bug description

Full_Name: henri dubois-ferriere
Version: 3.08.3
OS: debian
Submission from: lsne-catv-dhcp-41-122.urbanet.ch (80.238.41.122)

i just upgraded to 3.08.3, and by mistake did a 'make' in a directory which had
.cmi's compiled with 3.07 still lying around.

the error message was "misc.mli is not a compiled interface"

it would be good (esp for beginners who might get confused) if the error message
could say "this interface is compiled with another version of ocaml" or stg like
that.

thanks
henri

@vicuna

This comment has been minimized.

Copy link
Collaborator Author

vicuna commented Jul 29, 2013

Comment author: @gasche

Things should work as expected since (at least) 4.00.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.