Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"ocamldep -slash" bug #4050

Closed
vicuna opened this Issue Jun 20, 2006 · 1 comment

Comments

Projects
None yet
2 participants
@vicuna
Copy link
Collaborator

vicuna commented Jun 20, 2006

Original bug ID: 4050
Reporter: monate
Assigned to: @xavierleroy
Status: closed (set by @xavierleroy on 2007-02-21T14:51:12Z)
Resolution: fixed
Priority: normal
Severity: minor
Version: 3.09.2
Fixed in version: 3.10+dev
Category: ~DO NOT USE (was: OCaml general)
Monitored by: monate

Bug description

Bonjour,

Small problem with ocamldep -slash : using "ocamldep -slash -I +lablgtk2" under windows with ocamlmingw, leads to dependencies containing ''.

a.cmo: C:/ocamlmgw/lib\lablgtk2/gtkWindow.cmo

This comes form the call to Misc.expand_directory in ocamldep.ml.
Misc.expand_directory calls Filename.concat which peeks the standard windows '' separator without honouring the -slash option.

Thanks again for making such a nice compiler.
Cheers
Benjamin

@vicuna

This comment has been minimized.

Copy link
Collaborator Author

vicuna commented Aug 30, 2006

Comment author: @xavierleroy

Tentative fix in CVS trunk (for 3.10). To be tested.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.