Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ocamlbuild does not create symlinks to executables when targets are invoked via *.itarget #4552

Closed
vicuna opened this Issue May 8, 2008 · 0 comments

Comments

Projects
None yet
1 participant
@vicuna
Copy link
Collaborator

commented May 8, 2008

Original bug ID: 4552
Reporter: zack
Assigned to: @xclerc
Status: closed (set by @xavierleroy on 2012-03-24T14:01:41Z)
Resolution: fixed
Priority: normal
Severity: minor
Version: 3.10.1
Fixed in version: 3.12.1+dev
Category: -for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues

Bug description

I'm using foo.itarget to group targets to be invoked via "ocamlbuild foo.otarget".
My foo.itarget is as follows:

$ cat foo.itarget
test.byte
test.native

If I manually pas the two targets to ocamlbuild (e.g. "ocamlbuid test.byte") the executable is build properly and symlinked in the current directory from _build.
On the contrary, if I run "ocamlbuild foo.itarget" both executables are compiled, but they are not symlinked to the current directory.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.