Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

.mlpack dependencies not considered while building? #4592

Closed
vicuna opened this Issue Aug 1, 2008 · 1 comment

Comments

Projects
None yet
1 participant
@vicuna
Copy link
Collaborator

vicuna commented Aug 1, 2008

Original bug ID: 4592
Reporter: jaked
Assigned to: meyer
Status: closed (set by @xavierleroy on 2015-12-11T18:19:37Z)
Resolution: fixed
Priority: normal
Severity: major
Version: 3.10.2
Target version: 4.00.2+dev
Fixed in version: 4.01.0+dev
Category: -for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues
Has duplicate: #5752

Bug description

In the attached example, if you 'ocamlbuild main.byte', quux.cmo (needed by foo.cmo) is not built so the build fails; but if you remove quux.mli it works (by accident I think--it builds quux.cmo in order to get quux.cmi). If foo and foo.mlpack are replaced by a foo.ml defining the same structure it works.

Additional information

See also:

http://www.nabble.com/ocamlbuild-bug-(-)-with--pack-and-.d.byte-p11477766.html

File attachments

@vicuna

This comment has been minimized.

Copy link
Collaborator Author

vicuna commented Jan 23, 2013

Comment author: meyer

It's a user problem, mlpack will not include automatically the directory, therefore it should look like this:

foo.mlpack:
foo/Bar

not like this:

foo.mlpack:
Bar

Possibly maybe there was another problem linked, but that's been fixed already.

Closing this PR.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.