Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Patch for #0004841 doesn't solve the problem on PowerPC processors #4930

Closed
vicuna opened this Issue Nov 26, 2009 · 1 comment

Comments

Projects
None yet
1 participant
@vicuna
Copy link
Collaborator

vicuna commented Nov 26, 2009

Original bug ID: 4930
Reporter: monipol
Status: closed (set by @xavierleroy on 2009-11-26T15:31:30Z)
Resolution: fixed
Priority: normal
Severity: block
Version: 3.11.1
Fixed in version: 3.11.2+dev
Category: ~DO NOT USE (was: OCaml general)

Bug description

While trying to build Unison on Mac OS X, PowerPC:

/Developer/usr/bin/gcc-4.0 -arch ppc -L/sw/src/fink.build/unison-aqua-2.27.57-1008/unison-2.13.16/uimac/build/Default -F/sw/src/fink.build/unison-aqua-2.27.57-1008/unison-2.13.16/uimac/build/Default -filelist /sw/src/fink.build/unison-aqua-2.27.57-1008/unison-2.13.16/uimac/build/uimac.build/Default/uimac.build/Objects-normal/ppc/Unison.LinkFileList -mmacosx-version-min=10.5 /sw/src/fink.build/unison-aqua-2.27.57-1008/unison-2.13.16/uimac/../unison-blob.o -L/sw/lib/ocaml -lunix -lstr -lasmrun -framework Cocoa -framework Security -o /sw/src/fink.build/unison-aqua-2.27.57-1008/unison-2.13.16/uimac/build/Default/Unison.app/Contents/MacOS/Unison

Undefined symbols:
"_caml_apply2", referenced from:
_caml_callback2_exn in libasmrun.a(power.o)
_caml_callback2_exn in libasmrun.a(power.o)
"_caml_apply3", referenced from:
_caml_callback3_exn in libasmrun.a(power.o)
_caml_callback3_exn in libasmrun.a(power.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
** BUILD FAILED **

Additional information

The fix in the 3.11 bugfix branch for i386 and amd64 does not apply to powerpc.

From asmcomp/i386/emit.mlp:

if macosx
&& not !Clflags.output_c_object
&& is_generic_function fundecl.fun_name
then (* #4690 *)
.private_extern {emit_symbol fundecl.fun_name}\n
else
.globl {emit_symbol fundecl.fun_name}\n;

whilst in asmcomp/power/emit.mlp:

if Config.system = "rhapsody" && is_generic_function fundecl.fun_name
then (* #4690 *)
.private_extern {emit_symbol fundecl.fun_name}\n
else
.globl {emit_symbol fundecl.fun_name}\n;

@vicuna

This comment has been minimized.

Copy link
Collaborator Author

vicuna commented Nov 26, 2009

Comment author: @xavierleroy

Thanks for spotting this. The fix for i386 and amd64 is now propagated to the powerpc code generator. Will go in release 3.11.2.

@vicuna vicuna closed this Nov 26, 2009

@vicuna vicuna added the bug label Mar 20, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.