Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bad interaction between camlp4o and optional arguments #4937

Closed
vicuna opened this issue Dec 10, 2009 · 1 comment

Comments

Projects
None yet
1 participant
@vicuna
Copy link

commented Dec 10, 2009

Original bug ID: 4937
Reporter: pveber
Assigned to: @xclerc
Status: closed (set by @xavierleroy on 2012-09-25T18:06:17Z)
Resolution: fixed
Priority: normal
Severity: major
Version: 3.11.1
Fixed in version: 3.12.1+dev
Category: -for Camlp4 use https://github.com/ocaml/camlp4/issues
Related to: #4884

Bug description

The following program is incorrectly preprocessed by camlp4 :

~ 12:59:36 $ cat rien.mli
type option = int
val f : ?l:bool -> unit
~ 12:56:56 $ ocamlc -pp camlp4o -c rien.mli
File "rien.mli", line 2, characters 8-23:
Error: The type constructor option expects 0 argument(s),
but is here applied to 1 argument(s)

Sorry I couldn't guess the source of the problem !
ph.

@vicuna

This comment has been minimized.

Copy link
Author

commented Dec 10, 2009

Comment author: pveber

Yes the problem appears to be similar to issue 4884 (apologies for missing that one), but I should stress that in my case camlp4 is necessary for the problem to appear :

ocamlc -c rien.mli

works just fine. Anyway thanks for this lightning-fast reaction !
ph.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.