Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

objinfo outputs C objects in wrong order #4949

Closed
vicuna opened this Issue Dec 28, 2009 · 1 comment

Comments

Projects
None yet
1 participant
@vicuna
Copy link
Collaborator

vicuna commented Dec 28, 2009

Original bug ID: 4949
Reporter: gerd
Status: closed (set by @damiendoligez on 2010-01-07T15:06:51Z)
Resolution: fixed
Priority: normal
Severity: minor
Version: 3.11.1
Fixed in version: 3.12.0+dev
Category: ~DO NOT USE (was: OCaml general)
Monitored by: mehdi

Bug description

For example:

$ ocamlc -a -cclib -l1 -cclib -l2 -o t.cma t.cmo
$ objinfo t.cma
File t.cma
Force custom: no
Extra C object files: -l2 -l1
...

When a real link is done, the order is again reverted. I think objinfo should be changed to report the final order - which would be less confusing. objinfo is especially useful for diagnosing this kind of problem.

@vicuna

This comment has been minimized.

Copy link
Collaborator Author

vicuna commented Jan 7, 2010

Comment author: @damiendoligez

Fixed in trunk.

@vicuna vicuna closed this Jan 7, 2010

@vicuna vicuna added the bug label Mar 20, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.