Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ocamlopt generates duplicate symbols on arm #5030

Closed
vicuna opened this Issue Apr 20, 2010 · 1 comment

Comments

Projects
None yet
2 participants
@vicuna
Copy link
Collaborator

vicuna commented Apr 20, 2010

Original bug ID: 5030
Reporter: @glondu
Assigned to: @xavierleroy
Status: closed (set by @xavierleroy on 2011-05-29T10:19:42Z)
Resolution: fixed
Priority: normal
Severity: major
Fixed in version: 3.12.0+dev
Category: ~DO NOT USE (was: OCaml general)

Bug description

Hello,

While rebuilding all Debian packages (armel port) with ocamlopt enabled (using trunk r10268), ssreflect failed to build. The build log is available at [1].

The assembler is complaining about multiple definitions of the same symbol. This error doesn't occur on amd64.

Cheers,

--
Stéphane

Additional information

[1] http://debian.glondu.net/debian/ocaml31120dev17r10268/failures/ssreflect_1.2%2Bdfsg-4%2B3.12.0%2Bdev17%2B10268_armel.build

@vicuna

This comment has been minimized.

Copy link
Collaborator Author

vicuna commented Apr 22, 2010

Comment author: @xavierleroy

Fixed in SVN trunk. Data labels were starting too low, causing clashes. This was fixed earlier on other platforms but not on ARM.

@vicuna vicuna closed this May 29, 2011

@vicuna vicuna added the bug label Mar 20, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.