Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Verbose parameter should implicitly set classic display #5300

Closed
vicuna opened this issue Jun 22, 2011 · 2 comments
Closed

Verbose parameter should implicitly set classic display #5300

vicuna opened this issue Jun 22, 2011 · 2 comments

Comments

@vicuna
Copy link

@vicuna vicuna commented Jun 22, 2011

Original bug ID: 5300
Reporter: arj
Assigned to: @xclerc
Status: closed (set by @xavierleroy on 2015-12-11T18:08:14Z)
Resolution: fixed
Priority: normal
Severity: feature
Version: 3.13.0+dev
Category: -for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues

Bug description

When running

$ ocamlbuild -verbose 3

it is no more verbose than without the parameter "-verbose 3" as the interactive, non-classical view, is default.

One has to apply the switch "-classic-display" additionally to get the desired output.

$ ocamlbuild -verbose 3 -classic-display

I would suggest setting -classic-display automatically when -verbose is given.

Attached you see a suggestion for a patch.

File attachments

@vicuna
Copy link
Author

@vicuna vicuna commented Jun 27, 2011

Comment author: @ygrek

It becomes verbose in _build/_log and it is fine and predictable behaviour imho.

@vicuna
Copy link
Author

@vicuna vicuna commented Oct 10, 2012

Comment author: @xclerc

Fixed in trunk (revision 13000) and 4.00 (revision 12999) branches.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant