Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ocamlbuild, no way to pass command line flags to ocamldoc ? #5531

Closed
vicuna opened this issue Mar 9, 2012 · 2 comments

Comments

Projects
None yet
1 participant
@vicuna
Copy link

commented Mar 9, 2012

Original bug ID: 5531
Reporter: @dbuenzli
Assigned to: meyer
Status: closed (set by @xavierleroy on 2013-08-31T10:49:07Z)
Resolution: fixed
Priority: normal
Severity: feature
Version: 3.12.1
Category: -for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues
Monitored by: @gasche mehdi @xclerc @hcarty @dbuenzli

Bug description

Unless I'm mistaken there's no way to pass command line flags to ocamldoc. Up to now I was using

ocamlbuild -ocamldoc "ocamldoc $OCAMLDOCFLAGS"

but that doesn't work if you use ocamlbuild -use-ocamlfind.

Maybe something like -ocamldocflag -ocamldocflags.

Thanks,

Daniel

@vicuna

This comment has been minimized.

Copy link
Author

commented Apr 25, 2012

Comment author: meyer

Fixed on trunk with SVN r12395. Considered to be pushed soon into 4.0.

@vicuna

This comment has been minimized.

Copy link
Author

commented Apr 26, 2012

Comment author: meyer

.. and in 4.0 as r12402

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.