Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

disabling shared libraries does not work #5715

Closed
vicuna opened this issue Aug 3, 2012 · 3 comments
Closed

disabling shared libraries does not work #5715

vicuna opened this issue Aug 3, 2012 · 3 comments

Comments

@vicuna
Copy link

@vicuna vicuna commented Aug 3, 2012

Original bug ID: 5715
Reporter: @lefessan
Status: closed (set by @xavierleroy on 2015-12-11T18:08:08Z)
Resolution: unable to duplicate
Priority: normal
Severity: minor
Version: 4.00.0
Category: configure and build/install

Bug description

I tried to compile OCaml 4.00.0 with disabled shared libraries using:

generated by ./configure --prefix /home/lefessan/.ocaml/roots/ocaml-4.00.0 -with-debug-runtime -no-shared-libs

and compilation failed at:

make[3]: Entering directory `/home/lefessan/devel/ocaml-4.00.0/otherlibs/labltk/lib'
../../../ocamlcomp.sh -verbose -linkall -o labltktop -I ../support
../../../compilerlibs/ocamlcommon.cma ../../../compilerlibs/ocamlbytecomp.cma ../../../compilerlibs/ocamltoplevel.cma
-I ../../../otherlibs/unix -I ../../../otherlibs/win32unix unix.cma
-I ../labltk -I ../camltk labltk.cma
-I ../../../otherlibs/str str.cma
../../../toplevel/topstart.cmo
File "none", line 1:
Error: Error on dynamically loaded library: ../../../otherlibs/unix/dllunix.so: dynamic loading not supported on this platform
make[3]: *** [labltktop] Error 2

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 4, 2012

Comment author: @xavierleroy

"- Doctor, it hurts when I disable shared libraries.

  • Well, don't do that, then."

More technically: something is weird indeed, since in your configuration, the various .cma libraries should contain the "force -custom mode" flag. You should use ocamlobjinfo to check unix.cma, labltk.cma and str.cma. If the "force custom" flag is not here, check how ocamlmklib was configured.

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 8, 2012

Comment author: @damiendoligez

Which OS are you using? Did you do "make clean distclean" before configure?

On Mac OS X, I don't get any error. On Cygwin, I get a different error (because C libraries are passed with -ccopt instead of -cclib, and they get linked in the wrong order -- I'm going to fix that).

@vicuna
Copy link
Author

@vicuna vicuna commented Sep 24, 2012

Comment author: @xavierleroy

In the absence of new data, let me mark this PR as "unable to reproduce".

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

1 participant