Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot install trunk on OSX 10.6.8 #5912

Closed
vicuna opened this issue Jan 29, 2013 · 14 comments
Closed

Cannot install trunk on OSX 10.6.8 #5912

vicuna opened this issue Jan 29, 2013 · 14 comments

Comments

@vicuna
Copy link

@vicuna vicuna commented Jan 29, 2013

Original bug ID: 5912
Reporter: tgazagna
Assigned to: @damiendoligez
Status: closed (set by @xavierleroy on 2015-12-11T18:23:55Z)
Resolution: won't fix
Priority: high
Severity: minor
OS: OSX
OS Version: 10.6.8
Version: 4.01.0+dev
Target version: 4.01.0+dev
Fixed in version: 4.01.0+dev
Category: configure and build/install
Monitored by: tgazagna meurer @damiendoligez

Bug description

I have OSX 10.6.8 and I got:

[...]
/var/folders/xX/xX11ISOtFjiytGYgrXdr6U+++TI/-Tmp-/cc-ZGZMwX.s:4179:2: warning: ignoring directive for now
.cfi_endproc
^
for i in unix str num dynlink bigarray systhreads threads graph labltk; do
(cd otherlibs/$i; make allopt) || exit $?;
done
../../ocamlcompopt.sh -c -w +33..39 -warn-error A -g -nolabels unix.ml

and then the script seems to be stuck. I guess this is due to the recent swtich from as to llvm-as. I guess the configure script should check for the right version of OSX as well.

@vicuna
Copy link
Author

@vicuna vicuna commented Feb 26, 2013

Comment author: @damiendoligez

note: should probably check the version of as rather than the version of OSX.

@vicuna
Copy link
Author

@vicuna vicuna commented Feb 26, 2013

Comment author: tgazagna

$ as -v
Apple Inc version cctools-800~26, GNU assembler version 1.38

@vicuna
Copy link
Author

@vicuna vicuna commented Jun 19, 2013

Comment author: @damiendoligez

We'll need to find an OSX 10.6 machine to test this out. Or is it linked to the Xcode version? What about deciding that older versions of OSX are not supported?

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 20, 2013

Comment author: @bobzhang

I have an OSX 10.6.8 at home, I would help test tonight

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 20, 2013

Comment author: @bobzhang

unfortunately, I did not notice my mac was upgraded to 10.7.4.
it's fine for my machine
>as -v
Apple Inc version cctools-806
3, GNU assembler version 1.38

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 21, 2013

Comment author: tgazagna

I still get the issue with beta1:

A lot of "warning: ignoring directive for now .cfi_endproc"
and then: "../../ocamlcompopt.sh -c -w +33..39 -warn-error A -g -nolabels unix.ml" which hungs for ever.

Same config as first reported:
OSX 10.6.8
$ as -v
Apple Inc version cctools-800~26, GNU assembler version 1.38

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 21, 2013

Comment author: @damiendoligez

On my 10.6.8 machine, I have XCode 3.2.6 (the latest free version that works on 10.6),
as -v reports "Apple Inc version cctools-795~45, GNU assembler version 1.38",
OCaml's configure tells me that CFI is not available, and of course everything compiles without problem.

The latest non-free version of XCode available for 10.6 is XCode 4.2. Is that what you have?

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 21, 2013

Comment author: tgazagna

I have indeed a more recent version of XCode:

$ /Developer/usr/bin/xcodebuild -version
Xcode 4.0.2
Build version 4A2002a

I'll try to upgrade/downgrade to see it this has any impact.

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 21, 2013

Comment author: tgazagna

Actually Xcode 4.2 seems to not be available anywhere so I can't test it.

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 21, 2013

Comment author: @damiendoligez

XCode 4.2 is here: https://developer.apple.com/downloads/index.action#
Check only "Developer Tools" on the left and type "snow" in the search box at the top left.
You need a (paying) developer account to get this version, that's what I meant by "non-free", but 4.0.2 is available under the same terms, so you probably do have an account.

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 21, 2013

Comment author: @damiendoligez

I installed 4.0.2 and reproduced your problem: configure calls clang to test for .cfi support, but clang gives only a warning rather than an error, so configure continues as if .cfi was supported. I've no idea why it makes ocamlc.opt loop, but all those warnings are unhealthy anyway.

clang supports the -Werror option, but unfortunately it ignores it, so we can't use it in configure.

Possible solutions:

  1. detect XCode version and disable CFI for this version.
  2. grep the warning in clang's output.

Both solutions are ugly and I'm now downloading XCode 4.2. Hopefully it will fix the problem, and I will close this PR as "won't fix" unless you object strongly.

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 22, 2013

Comment author: @damiendoligez

With XCode 4.2 it works (with CFI).

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 23, 2013

Comment author: tgazagna

I managed to update to 4.2 and I confirm that it works. Thanks for looking at it! I'm fine with the "won't fix" / -no-cfi workaround.

@vicuna
Copy link
Author

@vicuna vicuna commented Aug 23, 2013

Comment author: @damiendoligez

FTR:

XCode 4.2: works with CFI
XCode 4.1: I couldn't install this version of XCode
XCode 4.0.2: fails
XCode 4.0.1: fails
XCode 3.2.6: works without CFI

I added a configure option (-no-cfi) and a mention in the INSTALL file. (branch 4.01, rev 14033).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants