Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Warning about trigraph on generated assembly code #6373

Closed
vicuna opened this issue Apr 17, 2014 · 2 comments
Closed

Warning about trigraph on generated assembly code #6373

vicuna opened this issue Apr 17, 2014 · 2 comments
Assignees

Comments

@vicuna
Copy link

@vicuna vicuna commented Apr 17, 2014

Original bug ID: 6373
Reporter: @damiendoligez
Assigned to: @mshinwell
Status: resolved (set by @mshinwell on 2017-03-10T11:02:17Z)
Resolution: duplicate
Priority: low
Severity: tweak
OS: Mac OS X
OS Version: 10.7.5
Version: 4.02.0+dev
Target version: undecided
Category: back end (clambda to assembly)

Bug description

String constants that contains C-style trigraphs trigger warnings from the assembler.

I've no idea why the assembler would want to interpret trigraphs or warn about them...

Steps to reproduce

----- foo.ml -----
let x = "??'"

$ ocamlopt foo.ml
/tmp/camlasm5799be.s:22:10: warning: trigraph ignored [-Wtrigraphs]
.ascii "??'"
^
1 warning generated.
$

@vicuna
Copy link
Author

@vicuna vicuna commented Mar 10, 2017

Comment author: @mshinwell

Fixed by #1093

@vicuna vicuna closed this Mar 10, 2017
@vicuna
Copy link
Author

@vicuna vicuna commented Oct 4, 2018

Comment author: pmetzger

So far as I can tell, this is not actually fixed. Running the test suite results in an error under MacOS 10.14 with Xcode 10 when I'm testing 4.07.1

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.