Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Ocamldoc output differs if compiled with clang #7521

Closed
vicuna opened this issue Apr 25, 2017 · 6 comments

Comments

Projects
None yet
2 participants
@vicuna
Copy link

commented Apr 25, 2017

Original bug ID: 7521
Reporter: schommer
Assigned to: @Octachron
Status: resolved (set by @Octachron on 2017-05-04T12:39:58Z)
Resolution: not a bug
Priority: normal
Severity: minor
Platform: amd64
OS: opensuse
OS Version: 42.2
Version: 4.04.1
Category: ocamldoc
Monitored by: @gasche

Bug description

The reference tests:
tests/tool-ocamldoc-2/inline_records.mli
tests/tool-ocamldoc-2/inline_records_bis.ml

fail with the following diffs:
--- tests/tool-ocamldoc-2/inline_records_bis.result 2017-04-25 16:26:07.413129690 +0200
+++ tests/tool-ocamldoc-2/inline_records_bis.reference 2017-04-25 15:25:40.209075702 +0200
@@ -283,4 +283,4 @@

Two new constructors for ext

-\end{document}
\ No newline at end of file
+\end{document}

and

--- tests/tool-ocamldoc-2/inline_records.result 2017-04-25 16:26:07.333132267 +0200
+++ tests/tool-ocamldoc-2/inline_records.reference 2017-04-25 15:25:40.209075702 +0200
@@ -284,4 +284,4 @@
\end{ocamldocdescription}

-\end{document}
\ No newline at end of file
+\end{document}

These tests worked with 4.04.

Steps to reproduce

configure ocaml with -cc clang and execute make world.opt; make tests

@vicuna

This comment has been minimized.

Copy link
Author

commented May 3, 2017

Comment author: @Octachron

I failed to reproduce the issue on both 4.04.1 and trunk with clang 4.0.0 on linux. Could you precise the version of clang that lead to the test suite failure?

@vicuna

This comment has been minimized.

Copy link
Author

commented May 3, 2017

Comment author: schommer

I'm also using clang 4.0 and configuration options:
-with-frame-pointers

I just noted that I also had applied:
#919

but this patch should be applied on trunk.

@vicuna

This comment has been minimized.

Copy link
Author

commented May 3, 2017

Comment author: @Octachron

Unfortunately, I am unable to reproduce this test failure on a freshly cloned ocaml repository.

@vicuna

This comment has been minimized.

Copy link
Author

commented May 4, 2017

Comment author: schommer

I can not reproduce it too with a freshly cloned ocaml. Seems to be a problem with our git repo, so this can be closed.

@vicuna

This comment has been minimized.

Copy link
Author

commented May 4, 2017

Comment author: @Octachron

I am marking this issue as resolved, since clang does not seem to be the root cause of the problem here.

Nevertheless, I suspect that the non-standard ending of ocamldoc generated latex files may be related to the issue at hand. Since this issue is straightforward to fix, I have opened a corresponding github PR at #1159 .

@vicuna vicuna closed this May 4, 2017

@vicuna

This comment has been minimized.

Copy link
Author

commented May 4, 2017

Comment author: schommer

Okay

@vicuna vicuna added the ocamldoc label Mar 14, 2019

@vicuna vicuna added the bug label Mar 20, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.