Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

AFL test broken #7725

Closed
vicuna opened this issue Feb 13, 2018 · 3 comments

Comments

Projects
None yet
2 participants
@vicuna
Copy link

commented Feb 13, 2018

Original bug ID: 7725
Reporter: @shindere
Assigned to: @gasche
Status: resolved (set by @gasche on 2018-05-10T12:15:53Z)
Resolution: fixed
Priority: normal
Severity: trivial
Version: 4.07.0+dev/beta2/rc1/rc2
Target version: 4.07.0+dev/beta2/rc1/rc2
Fixed in version: 4.08.0+dev/beta1/beta2
Category: misc

Bug description

When actually ran (afl-showmap available and compiler configured with -afl-instrument) this test fails. Was not able to find a version on trunk where this works, not even after #1345 was merged, whereas it was supposed to fix the "class" test which is the one that is broken.

Steps to reproduce

./configure -afl-instrument
make world.opt
cd testsuite
make one DIR=tests/afl-instrumentation

@vicuna

This comment has been minimized.

Copy link
Author

commented Feb 13, 2018

Comment author: @gasche

The tests are known to work when ./configure -afl-instrument is not used. It would be correct to disable them when ./configure -afl-instrument was set.

(Note: configure-time ./configure -afl-instrument is not necessary to enable compilation-time -afl-instrument on a file-by-file basis.)

@vicuna

This comment has been minimized.

Copy link
Author

commented May 2, 2018

Comment author: @stedolan

Apologies that this took me so long to get around to! There's a fix in #1754 now.

@vicuna

This comment has been minimized.

Copy link
Author

commented May 10, 2018

Comment author: @stedolan

#1754 merged, so this is fixed.

@vicuna vicuna closed this May 10, 2018

@vicuna vicuna added this to the 4.07.0 milestone Mar 14, 2019

@vicuna vicuna added the bug label Mar 20, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.