Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

frametable alignment problem on ARM64 #7887

Closed
vicuna opened this issue Dec 28, 2018 · 0 comments
Closed

frametable alignment problem on ARM64 #7887

vicuna opened this issue Dec 28, 2018 · 0 comments
Labels
Milestone

Comments

@vicuna
Copy link

@vicuna vicuna commented Dec 28, 2018

Original bug ID: 7887
Reporter: @damiendoligez
Status: new
Resolution: open
Priority: normal
Severity: major
Version: 4.07.1
Target version: 4.08.0+dev/beta1/beta2
Category: back end (clambda to assembly)
Related to: #7591
Monitored by: @nojb

Bug description

This was reported here: 22dbcdf#commitcomment-31308644

@vicuna vicuna added this to the 4.08.0 milestone Mar 14, 2019
xavierleroy added a commit to xavierleroy/ocaml that referenced this issue Mar 29, 2019
@nojb nojb removed this from the 4.08.0 milestone Mar 29, 2019
@nojb nojb added this to the 4.08 milestone Mar 29, 2019
gasche added a commit that referenced this issue Jul 17, 2019
This is a follow-up to commit 7077b60 that fixed a lack of 8-alignment for the frame table on ADM64, as reported in #7591.
A similar issue was reported in #7887 for ARM64 and is fixed here.
For good measure, explicit alignment was added  to PPC64 as well, although there was probably no issue there.

Closes: #7887.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants