New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

also install ocamlyacc #1048

Closed
wants to merge 1 commit into
base: trunk
from

Conversation

Projects
None yet
5 participants
@fdopen
Contributor

fdopen commented Feb 17, 2017

I've just tried the new 4.05.0+beta1 switch. And there is no ocamlyacc in $(opam config var bin).

ping @shindere

@shindere

This comment has been minimized.

Show comment
Hide comment
@shindere

shindere Feb 17, 2017

Contributor
Contributor

shindere commented Feb 17, 2017

@nojb

This comment has been minimized.

Show comment
Hide comment
@nojb

nojb Feb 17, 2017

Contributor

Also needs to be added to installopt and installoptopt rules I think.

Contributor

nojb commented Feb 17, 2017

Also needs to be added to installopt and installoptopt rules I think.

@shindere

This comment has been minimized.

Show comment
Hide comment
@shindere

shindere Feb 17, 2017

Contributor
Contributor

shindere commented Feb 17, 2017

@nojb

This comment has been minimized.

Show comment
Hide comment
@nojb

nojb Feb 17, 2017

Contributor

Right, good point.

Contributor

nojb commented Feb 17, 2017

Right, good point.

@fdopen

This comment has been minimized.

Show comment
Hide comment
@fdopen

fdopen Feb 17, 2017

Contributor

Yes, and therefore the ocamlyacc.byte symlink looks dubious. I've removed it now.

Contributor

fdopen commented Feb 17, 2017

Yes, and therefore the ocamlyacc.byte symlink looks dubious. I've removed it now.

@shindere

This comment has been minimized.

Show comment
Hide comment
@shindere

shindere Feb 17, 2017

Contributor
Contributor

shindere commented Feb 17, 2017

@gasche

This comment has been minimized.

Show comment
Hide comment
@gasche

gasche Feb 17, 2017

Member

Is that not a feature? We could have make install print

ocamlyacc is deprecated, please use Menhir instead.

(Joking. In practice we would have a moderately nicer deprecation path.)

Member

gasche commented Feb 17, 2017

Is that not a feature? We could have make install print

ocamlyacc is deprecated, please use Menhir instead.

(Joking. In practice we would have a moderately nicer deprecation path.)

@shindere

This comment has been minimized.

Show comment
Hide comment
@shindere

shindere Feb 17, 2017

Contributor

Cherry-picked on trunk and 4.05, thanks.
Sorry if GitHub does not see it.

Contributor

shindere commented Feb 17, 2017

Cherry-picked on trunk and 4.05, thanks.
Sorry if GitHub does not see it.

@shindere

This comment has been minimized.

Show comment
Hide comment
@shindere

shindere Feb 17, 2017

Contributor
Contributor

shindere commented Feb 17, 2017

@dra27

This comment has been minimized.

Show comment
Hide comment
@dra27

dra27 Feb 17, 2017

Contributor

9174a1d on trunk and 2b64846 on 4.05. GitHub can't relate cherry-picks to GPRs, so closing.

Contributor

dra27 commented Feb 17, 2017

9174a1d on trunk and 2b64846 on 4.05. GitHub can't relate cherry-picks to GPRs, so closing.

@dra27 dra27 closed this Feb 17, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment