Skip to content
Permalink
Fetching contributors…
Cannot retrieve contributors at this time
46 lines (45 sloc) 1.62 KB
opam-version: "2.0"
maintainer: "opensource@janestreet.com"
authors: ["Jane Street Group, LLC <opensource@janestreet.com>"]
homepage: "https://github.com/janestreet/core_extended"
license: "Apache-2.0"
build: [
[make]
]
remove: [["ocamlfind" "remove" "core_extended"]]
depends: [
"ocaml" {>= "4.02.1" & < "4.03"}
"camlp4"
"ocamlfind" {>= "1.3.2"}
"bin_prot" {>= "112.35.00" & < "112.36.00"}
"comparelib" {>= "109.27.00" & < "109.61.00"}
"core" {>= "112.35.00" & < "112.36.00"}
"custom_printf" {>= "112.24.00" & < "112.25.00"}
"fieldslib" {>= "109.20.00" & < "109.21.00"}
"pa_ounit" {>= "112.35.00" & < "112.36.00"}
"pa_test" {>= "112.24.00" & < "112.25.00"}
"pipebang" {>= "110.01.00" & < "110.02.00"}
"re2" {>= "112.35.00" & < "112.36.00"}
"sexplib" {>= "112.35.00" & < "112.36.00"}
"textutils" {>= "112.17.00" & < "112.18.00"}
"ocamlbuild" {build}
]
patches: [ "openbsd-quota-disable.diff" { (os = "openbsd") | (os = "freebsd") } ]
bug-reports: "https://github.com/janestreet/core_extended/issues"
dev-repo: "git+https://github.com/janestreet/core_extended.git"
install: [[make "install"]]
synopsis:
"Extra components that are not as closely vetted or as stable as Core"
description: """
The Core suite of libraries is an industrial strength alternative to
OCaml's standard library that was developed by Jane Street, the
largest industrial user of OCaml."""
flags: light-uninstall
extra-files: [
"openbsd-quota-disable.diff" "md5=e2b38305fc5b63ef66d0cdcbf7b0df0d"
]
url {
src:
"https://ocaml.janestreet.com/ocaml-core/112.35/files/core_extended-112.35.00.tar.gz"
checksum: "md5=834bcd5c4c5c3d0cfdf7d719fada7d7a"
}
You can’t perform that action at this time.