Permalink
Fetching contributors…
Cannot retrieve contributors at this time
31 lines (30 sloc) 1 KB
opam-version: "2.0"
maintainer: "frederic.bour@lakaban.net"
authors: [
"Frédéric Bour <frederic.bour@lakaban.net>"
"Jérémie Dimino <jeremie@dimino.org>"
]
license: "LGPL-2.1"
homepage: "https://github.com/let-def/ocaml-migrate-parsetree"
bug-reports: "https://github.com/let-def/ocaml-migrate-parsetree/issues"
dev-repo: "git://github.com/let-def/ocaml-migrate-parsetree.git"
tags: [ "syntax" "org:ocamllabs" ]
build: [
["jbuilder" "build" "-p" name "-j" jobs]
]
depends: [
"ocaml" {>= "4.02.0" & < "4.06.0"}
"result"
"ocamlfind" {build}
"jbuilder" {build & >= "1.0+beta10"}
]
conflicts: [ "dune" ]
synopsis: "Convert OCaml parsetrees between different versions"
description: """
This library converts parsetrees, outcometree and ast mappers between different OCaml versions.
High-level functions help making PPX rewriters independent of a compiler version."""
url {
src:
"https://github.com/ocaml-ppx/ocaml-migrate-parsetree/archive/v1.0.5.tar.gz"
checksum: "md5=3bb704c1d63c928b13f59e6a1ac8603d"
}