Skip to content
Permalink
Fetching contributors…
Cannot retrieve contributors at this time
40 lines (39 sloc) 1.18 KB
opam-version: "2.0"
synopsis: "current trunk, with flambda activated"
maintainer: "platform@lists.ocaml.org"
depends: [
"ocaml" {= "4.10.0" & post}
"base-unix" {post}
"base-bigarray" {post}
"base-threads" {post}
"ocaml-beta"
]
conflict-class: "ocaml-core-compiler"
flags: compiler
setenv: CAML_LD_LIBRARY_PATH = "%{lib}%/stublibs"
build: [
["./configure" "--prefix=%{prefix}%" "--enable-flambda"]
{os != "openbsd" & os != "freebsd" & os != "macos"}
[
"./configure"
"--prefix=%{prefix}%"
"--enable-flambda"
"CC=cc"
"ASPP=cc -c"
] {os = "openbsd" | os = "freebsd" | os = "macos"}
[make "-j%{jobs}%" {os != "cygwin"} "world"]
[make "-j%{jobs}%" {os != "cygwin"} "world.opt"]
]
install: [make "install"]
url {
src: "https://github.com/ocaml/ocaml/archive/trunk.tar.gz"
}
post-messages: [
"A failure in the middle of the build may be caused by build parallelism
(enabled by default).
See https://github.com/ocaml/opam-repository/pull/14257 for more info."
{failure & jobs > 1 & os != "cygwin"}
"You can try installing again including --jobs=1
to force a sequential build instead."
{failure & jobs > 1 & os != "cygwin" & opam-version >= "2.0.5"}
]
You can’t perform that action at this time.