Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

jbuilder 1.0+beta20.1 #15427

Merged
merged 1 commit into from Dec 2, 2019
Merged

jbuilder 1.0+beta20.1 #15427

merged 1 commit into from Dec 2, 2019

Conversation

@diml
Copy link
Member

diml commented Dec 2, 2019

This is the just a minor release of the original jbuilder package to make it compatible with OCaml 4.08.

Signed-off-by: Jeremie Dimino <jeremie@dimino.org>
@camelus

This comment has been minimized.

Copy link
Contributor

camelus commented Dec 2, 2019

Commit: 38badb1

A pull request by opam-seasoned @diml.

☀️ All lint checks passed 38badb1
  • These packages passed lint tests: jbuilder.1.0+beta20.1

☀️ Installability check (+1)
  • new installable packages (1): jbuilder.1.0+beta20.1
@kit-ty-kate

This comment has been minimized.

Copy link
Contributor

kit-ty-kate commented Dec 2, 2019

apart from kafka.0.3 all the revdeps failures seem unrelated.

#=== ERROR while compiling kafka.0.3 ==========================================#
# context              2.0.5 | linux/x86_64 | ocaml-base-compiler.4.09.0 | git+file:///home/opam/opam-repository
# path                 ~/.opam/4.09/.opam-switch/build/kafka.0.3
# command              ~/.opam/4.09/bin/jbuilder build -p kafka . -j 2 @install
# exit-code            1
# env-file             ~/.opam/log/kafka-25-0bec07.env
# output-file          ~/.opam/log/kafka-25-0bec07.out
### output ###
# Don't know how to build .
@avsm

This comment has been minimized.

Copy link
Member

avsm commented Dec 2, 2019

The kafka.0.3 one should be fixable by synching its build rule with kafka.0.4 (which doesnt include .)

@kit-ty-kate

This comment has been minimized.

Copy link
Contributor

kit-ty-kate commented Dec 2, 2019

This is now fixed. Thanks

@kit-ty-kate kit-ty-kate merged commit 6de3943 into ocaml:master Dec 2, 2019
6 of 7 checks passed
6 of 7 checks passed
ci/datakit/2 Revdeps revdep:jbuilder.1.0+beta20.1 failed
Details
camelus All tests passed
ci/datakit/1 Build Build
Details
ci/datakit/3 Compilers Compilers
Details
ci/datakit/4 Common Distros Common Distros
Details
ci/datakit/5 All Distros All Distros
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.