New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

core.v0.9.1 — via opam-publish #9250

Merged
merged 1 commit into from May 22, 2017

Conversation

Projects
None yet
3 participants
@diml
Member

diml commented May 22, 2017

Industrial strength alternative to OCaml's standard library

The Core suite of libraries is an industrial strength alternative to
OCaml's standard library that was developed by Jane Street, the
largest industrial user of OCaml.



opam-lint failures

  • ERROR 32 Field 'ocaml-version:' and variable 'ocaml-version' are deprecated, use a dependency towards the 'ocaml' package instead for availability, and the 'ocaml:version' package variable for scripts
  • ERROR 21 Field 'opam-version' doesn't match the current version, validation may not be accurate: "1.2"

Pull-request generated by opam-publish v0.3.4

@diml

This comment has been minimized.

Show comment
Hide comment
@diml

diml May 22, 2017

Member

/cc @avsm, this fixes the 4.05 compatibility

Member

diml commented May 22, 2017

/cc @avsm, this fixes the 4.05 compatibility

@camelus

This comment has been minimized.

Show comment
Hide comment
@camelus

camelus May 22, 2017

All lint checks passed 7765948
  • These packages passed lint tests: core.v0.9.1

Installability check (6753 → 6754)
  • new installable packages (1): core.v0.9.1

camelus commented May 22, 2017

All lint checks passed 7765948
  • These packages passed lint tests: core.v0.9.1

Installability check (6753 → 6754)
  • new installable packages (1): core.v0.9.1
Show outdated Hide outdated packages/core/core.v0.9.1/url
@@ -0,0 +1,2 @@
src: "https://github.com/janestreet/core/archive/v0.9.1.tar.gz"
checksum: "md5=ce86cbba19a9ced6502540ec887d7f99"

This comment has been minimized.

@avsm

avsm May 22, 2017

Member

bad checksum here... remove md5=

@avsm

avsm May 22, 2017

Member

bad checksum here... remove md5=

This comment has been minimized.

@diml

diml May 22, 2017

Member

fixed

@diml

diml May 22, 2017

Member

fixed

@avsm

avsm approved these changes May 22, 2017

@avsm avsm merged commit 19e1c53 into ocaml:master May 22, 2017

10 of 11 checks passed

ci/datakit/5 V2.0 All Distros Waiting for Debian Testing, Debian Unstable, OpenSUSE 42.2, Fedora 24
Details
camelus All tests passed
ci/datakit/1 V1.2 Build V1.2 Build
Details
ci/datakit/1 V2.0 Build V2.0 Build
Details
ci/datakit/2 V2.0 Revdeps V2.0 Revdeps
Details
ci/datakit/3 V1.2 Compilers V1.2 Compilers
Details
ci/datakit/3 V2.0 Compilers V2.0 Compilers
Details
ci/datakit/4 V1.2 Common Distros V1.2 Common Distros
Details
ci/datakit/4 V2.0 Common Distros V2.0 Common Distros
Details
ci/datakit/5 V1.2 All Distros V1.2 All Distros
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment