opam update fails on why/frama-c/ocaml-inifiles #205

Closed
yminsky opened this Issue Oct 3, 2012 · 10 comments

3 participants

@yminsky

When I do an "opam update" on the latest version from brew (0.7.2), I get the following error:

~ $ opam update
Fetching git://github.com/mirage/opam-repo-dev ...
Synchronizing with http://opam.ocamlpro.com ...
Package wdialog depends on the unknown package ocaml-inifiles
Package why depends on the unknown package frama-c
'opam update' failed

~ $

@samoht
OCaml member

This is fixed in releases >= 7.3. @avsm could you please update the brew version ?

@avsm
OCaml member

I upgraded the Homebrew OPAM to 0.7.3 a few days ago in ocaml-attic/homebrew-ocaml@2391685

I think we need the auto-update check in #166 really (although it might be annoying if it is displayed all the time)

@samoht
OCaml member

This problem is that old versions of opam sometime can't read the repository to know there is a new version available.

@avsm
OCaml member
@samoht
OCaml member
@yminsky
@avsm
OCaml member
@avsm
OCaml member

I've opened a Homebrew update request to the latest OPAM at Homebrew/legacy-homebrew#15279

@avsm
OCaml member

That was fast! They've merged it. I'll send a note to the Mirage list to deprecate my tap. Everyone should just use the mainline Homebrew version now...

@samoht
OCaml member

Ok, as homebrew is updated and as I've implemented #166, I'm closing this issue.

@samoht samoht closed this Oct 3, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment