Skip to content
This repository

Cannot build on Archlinux #2

Closed
SanskritFritz opened this Issue · 2 comments

2 participants

SanskritFritz octaspire
SanskritFritz

This is the package I'm using:
https://aur.archlinux.org/packages.php?ID=35118
Here is the build output:

/usr/bin/ld: CMakeFiles/crates.dir/src/oluacapi.c.o: undefined reference to symbol 'floor@@GLIBC_2.2.5'
/usr/bin/ld: note: 'floor@@GLIBC_2.2.5' is defined in DSO /lib/libm.so.6 so try adding it to the linker command line
/lib/libm.so.6: could not read symbols: Invalid operation

octaspire
Owner

I don't have access to archlinux distribution at the moment, so I cannot reproduce the problem or test this solution.

But if you want to try, you could change the line

cmake ..

to this one:

cmake .. -DCMAKE_EXE_LINKER_FLAGS="-lm"
SanskritFritz

This way it works, thank you!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.