Skip to content
Permalink
Browse files

[FIX] requirements: bump up jinja2 reqs

Recommended by GitHub's repository alerts.

We normally stick as close as possible to the version we depend
on in the official DEB packages. This in turn depends on the version of
Debian stable at the time of release - for 11.0 that would be Debian 9
(stretch) and thus Jinja 2.8 (with security backports).

However Jinja2 before 2.10.1 suffers from a few issues that could lead
to crashes of Odoo processes.

It seems it's worth an exception to our rule for pip users, similarly to
previous bump up at d2605bc.

closes #32601

Signed-off-by: Christophe Simonis <chs@odoo.com>
  • Loading branch information...
odony committed Apr 10, 2019
1 parent 330e1ea commit 6cbecced3d9ade705f7002bbca14477dcccd9297
Showing with 2 additions and 2 deletions.
  1. +1 −1 requirements.txt
  2. +1 −1 setup/win32/winpy_requirements.txt
@@ -8,7 +8,7 @@ gevent==1.3.4 ; sys_platform != 'win32' and python_version >= '3.7'
greenlet==0.4.10 ; python_version < '3.7'
greenlet==0.4.13 ; python_version >= '3.7'
html2text==2016.9.19
Jinja2==2.8.1
Jinja2==2.10.1
lxml==3.7.1 ; sys_platform != 'win32' and python_version < '3.7'
lxml==4.2.3 ; sys_platform != 'win32' and python_version >= '3.7'
lxml ; sys_platform == 'win32'
@@ -6,7 +6,7 @@ feedparser==5.2.1
gevent>=1.1.2
greenlet>=0.4.10
html2text==2016.9.19
Jinja2==2.8
Jinja2==2.10.1
lxml>=3.5.0
Mako==1.0.4
MarkupSafe==0.23

0 comments on commit 6cbecce

Please sign in to comment.
You can’t perform that action at this time.