Skip to content
Permalink
Browse files

[FIX] requirements: bump up jinja2 reqs

Recommended by GitHub's repository alerts.

We normally stick as close as possible to the version we depend
on in the official DEB packages. This in turn depends on the version of
Debian stable at the time of release - for 10.0 that would be Debian 8
(jessie) and thus Jinja 2.7.3 (albeit with security backports).

However Jinja2 before 2.10.1 suffers from a few issues that could lead
to crashes of Odoo processes.

It seems it's worth an exception to our rule for pip users, similarly to
previous bump up at d2605bc.

closes #32602

Signed-off-by: Christophe Simonis <chs@odoo.com>
  • Loading branch information...
odony committed Apr 10, 2019
1 parent 39fd19f commit 78ba90d54826c2ba11626e9a89b142964db25e2f
Showing with 1 addition and 1 deletion.
  1. +1 −1 requirements.txt
@@ -6,7 +6,7 @@ feedparser==5.2.1
gevent==1.1.2
greenlet==0.4.10
jcconv==0.2.3
Jinja2==2.8.1
Jinja2==2.10.1
lxml==3.5.0
Mako==1.0.4
MarkupSafe==0.23

0 comments on commit 78ba90d

Please sign in to comment.
You can’t perform that action at this time.